Zotero and Firefox Containers

I use Firefox with multi-account Containers (https://addons.mozilla.org/en-US/firefox/addon/multi-account-containers/) which is a way to prevent leaking of cookies and login information between different websites. In particular, I set up a "Job" container, associated to scientific journals' websites, for example those of the American Physical Society (aps.org).

APS policy is to put a verification page before a pdf can be downloaded (one has to click an image to prove not being a bot). In the past, I could use the APS Zotero connector to save a journal reference and it associated pdf, provided I had previously clicked on the verification image.

Now, I realized that if said webpage is inside my "Job" container, even if I first click on the verification image, then the Zotero connector is not able to download the pdf. I digged in Zotero log and found:

(2)(+0000016): Error: Downloaded PDF was not a PDF Error: Downloaded PDF was not a PDF Zotero.Attachments</this.downloadFile@chrome://zotero/content/xpcom/attachments.js:866:11 From previous event: Zotero.Server.DataListener.prototype._bodyData@chrome://zotero/content/xpcom/server.js:329:3 Zotero.Server.DataListener.prototype._headerFinished@chrome://zotero/content/xpcom/server.js:301:3 Zotero.Server.DataListener.prototype.onDataAvailable@chrome://zotero/content/xpcom/server.js:204:4

I guess Zotero is exiting the "Job" container when looking for the pdf, so it does not profit of the correct cookie which would give access to the pdf.

Has anybody encountered this problem? I understand it is a peculiar case, but could anybody suggest me a workaround, other that stopping using Firefox Containers?

Thank you very much
  • Have you tried saving again? It failed for me before verifying and once after verifying, but then after trying to save again (you need to refresh the page, to initiate another save), it works for all PDFs on the site.
  • No, if I use Firefox containers, I am not able to download PDFs from APS, even if I verify and the refresh the article page a few times, before trying to save with Zotero.

    However, I noticed that if force Firefox to open the verify page in the No context container, then I am able to save PDFs even from my "Job" context, for a few minutes. This makes sense, because the cookie is saved in the no context container.

    This is kind of ugly, because I set the APS websites to open automatically in my "Job" container, so I have to manually force the verification page in the No context container once per session.
  • Unless you can add an exception for the Zotero connector, I don't think there's much that can be done here.
  • Do you know whether there is a specific address of the Zotero connector that I could use? Thanks
  • Whatever is the initial path of Zotero Connector preferences (i.e.
  • I tried to modify the ~/.mozilla/firefox//browser-extension-data/@testpilot-containers/storage.js file by adding "siteContainerMap@@_moz-extension://6f59f309-bb15-46e7-aa2d-c7d72e9c3707/*":{"userContextId":"2","neverAsk":true} but it does not work. I guess the container add-on is not flexible enough to understand moz-extension://
  • Would it be possible for Zotero to stop the download and show the page asking for the captcha again, while remaining in the same default container? Or, even better, would it be possible for Zotero to look for the cookies in the same container as the article page? Thanks
  • I'm having the same issue. Works perfectly fine for PDFs on the default 'container' but if I have PDFs from journals open in my "Work" container, I cannot sync.
  • Did anyone find a workaround for this? I have the same issue of being unable to download full-text PDFs from proxied sites in firefox containers.
  • @fnadon -- are you using the multi-container add-on? If not, better to post it to a new thread with specific examples of pages from which PDF download is failing.
  • Yes, the multi-container add-on. Any page that requires a login (accessed via proxy) for downloading the PDF (e.g., https://journals.sagepub.com/doi/full/10.1177/02783649211004615 ) fails.
Sign In or Register to comment.