"You can not make changes to the currently selected collection"

We are a group of colleagues who have been using a shared library for years. There are 3 colleagues with admin rights and all others have normal write permissions. All at once, however, two colleagues can no longer make entries (from one day to the next). No matter in which collection they want to add an entry or want to create a new collection, the error message "You can not make changes to the currently selected collection." appears. We then tried to give these two people temporary admin rights, but this didn't change anything. Finally, we looked at whether these people can create a new collection on zotero.org, and interestingly, this was possible. However, through the local zotero application both can do nothing. Additional information: All PCs are configured in a similar way, and only 2 out of about 30 colleagues have the problem.
  • Shot in the dark: Maybe this is a sync problem... I've sometimes found you have to hit sync to get the latest changes (which would include permissions).
  • Syncing works well. If somebody else added a new reference this is also visible for that 2 people who get the error message.
  • We also tried to exclude the factors PC and location. We installed zotero on a fresh laptop located in another city and one of the 2 persons logged in and synced successfully. But the permission problem was the same.
  • To confirm (and help me think):
    - On zotero.org, those two can make changes to entries, as well as create collections?
    - When you look at the group permissions on zotero.org, those two users look identical to all others?

    In the Zotero standalone app (latest version):
    - The two users cannot make changes to entries, and cannot create collections?
  • edited July 30, 2018
    One of those two created a new collection on zotero.org, and after syncing this was visible for all of our users.
    And yes, the two users have identical rights/permissions on zotero.org in comparison to all other users.

    Regarding zotero standalone app: Yes, it is like you wrote.
  • Sorry, I'm running out of ideas... have you tried removing/readding them?

    I assume that the library isn't publicly visible, right? Otherwise is it possible that the username they are logged with on Zotero App differs from the username for Zotero.org?
  • You could also generate an error report and submit it?
  • I wouldn't remove and re-add them. That could cause more problems and shouldn't be necessary, and if there were some sort of sync bug, it should be enough to modify their user role or the group permissions again.
    We then tried to give these two people temporary admin rights, but this didn't change anything.
    If this is the group that the account you're posting from is the owner of, I only see one user account that's had its role changed recently.

    If it's another group, could you email support@zotero.org with the details of the group and affected users and a link to this thread?
  • edited July 31, 2018
    Hi Dan,
    yes, it's the account I'm writing from. As the two group members didn't have the same problem at the same time but with about 2 months distance, we've tried to give admin rights recently only for one person.
    I will send an error report number generated from the account where we changed the role recently (after logging the debug outputs) during the next hours.
  • The error ID is D529691476.
    It was generated with normal user rights and after successful syncing.
  • OK, and if you make a change to the group metadata (e.g., a change to the Description field) and then they sync? If that doesn't fix it, could we see a Debug ID that covers the first sync after such a change (which may happen immediately if auto-sync is enabled)?
  • Ok. The description field in the group settings on zotero.org was empty until today. I included a few words for testing.
    After that - on the laptop of one of the two collegues / the auto-sync was off until now - I started the debug output logging and started the syncing. After sync was finished I didn't get any ID and so I looked into the log protocol and made a copy but its too long to post it here. So were I can send it to?
  • What do you mean by "didn't get any ID"?
  • But you can ZIP and, if it's less than 10 MB, email to support@zotero.org with a link to this thread.
  • edited July 31, 2018
    OK... sorry, my collegue on the laptop didn't transmit the debug log to get a ticket ID but she clicked on "show output" and made copy&paste and sent it to me by email.
    Now I have forwarded it to support@zotero.org.
  • We haven't received anything, by the way.
  • edited July 31, 2018
    Didn't you still get it? Otherwise I would repead it...?
    .... the email subject was "debug logging (72974) - to Dan Stillman" ...
  • I have send now the log as a docx file to the support.
  • This is quite odd.

    If that person checks the database integrity from the Advanced → Files and Folders pane of their Zotero preferences, does it pass?

    Also, if they check in that pane, is the data directory in the default location or somewhere else?
  • The database integrity check was OK - no errors were detected in the database.
    Regarding your second question, we use the default location.
  • Dear Dan,
    any new idea?
    Kind regards...
  • Sorry for the delay. If they don't mind, could that person upload their database to the DB Repair Tool and could you post the Upload ID here? The repair process won't do anything, so they can ignore the download link the tool provides, but the Upload ID may let us run some tests to try to figure out what's happening here.
  • I wanted to sync prior to upload the database of my colleage but while syncing an error accured that the database could not be synced because the user has no writing rights for the database. The error ID is 1000672186.

    Nevertheless I have uploaded the database file (with sync date of last friday I think) and have got the following upload ID: 5b6988ef2db2f.
  • OK, this is a strange one. Somehow the userID in the uploaded database — and I'm guessing yours and your other colleagues' as well — was changed into an invalid format with a newline character appended to it. That's an unexpected state and was preventing updated group permissions from being properly applied during syncing.

    I can't figure out any way this could've occurred in the current codebase, but it's possible it happened in an earlier version of Zotero. Did everyone affected use Zotero 4 previously? I don't suppose by some chance you all used some third-party tool or plugin on your databases?

    In any case, this should be fixed if you install the Zotero beta. After running that once, you can revert to the official version. If you then make another change to the group's description and sync, the permissions should be corrected.
  • Sorry for the late reply but I was out of office for the last 3 weeks.
    We have installed the zotero beta as suggested and with that version at first the same error occurred. But after giving admin rights to the users everything worked correctly. After changing back to normal member rights everything still worked fine. Now we have to revert to the official version. After doing this I will give another feedback. Thank you meanwhile!
  • Today we made the update back to official zotero version 5.0.55, and everythings still works fine!
    Thank you for the great assistance and support!
Sign In or Register to comment.