Translator Proquest Ebook Central - nothing came thru after clicked folder

Hi: zotero 5.0.53 and fx
First time using this translator.

Clicked zotero (FOLDER icon showing) (2 search results on the screen)
Navigated to open zotero desktop app. nothing in there. Other translators are working.

Tried from my other proquest ebookcentral account. Same result (nothing)


2 Debug ID is D1011478984.

3 Popup says "Saving to My Library”

4 Translator name Proquest Ebook Central
  • edited July 23, 2018
    Fixed. Problem was cookie related.
    Zotero Connector requires you to allow cookies permanently. I have allow session cookies and it would not work. No error message received either.

    How many cookies does Zotero Connector set to import into Zotero App on FX/mac sierra setup?
    Where do I find the names of the cookies required by Zotero Connector?

    Found this cookie. Is it set by zotero connector?
    host =
    Send For = any type of connection
    content = desktop-1
  • Cookies are set by sites, not by the Zotero Connector. Restrictive cookie settings can prevent Firefox from sending cookies back to the website when the Zotero Connector tries to save. (In this case, that results in your getting an login page rather than the expected RIS file.)

    If you say the exact settings you're using, we can try to see what's happening here. I'm able to save from the basic ProQuest search with Firefox set to expires cookies when I close the browser. I don't have access to Ebook Central, though, so if it's specific to that, someone else may need to try to reproduce this.
  • If you say the exact settings you're using,

    Hi, I provided these at the first post. Will the error report.
  • I provided these at the first post
    No, you didn't. I'm talking about the exact Firefox settings — with verbatim text — that are triggering this.
Sign In or Register to comment.