xml or ris for importing from End Note

I see advice in your documentation to use xml as the file format, while other guides say to use RIS. Is the XML suggestion up to date? Is one safer than the other?
  • Zotero is able to import either.

    Endnote XML is a newer and richer format, so may preserve a bit more than RIS when exporting from Endnote. Endnote XML is likely a better "default" format, but either should bring in 90+% of what you'd like.

    Note that Endnote has made undocumented changes to both of these and not all people store information in Endnote in the same way. This sometimes prevents getting to 100% out-of-the-box. Inspect records that you've imported. If you notice any undesired behavior, it is better to catch them early. Searching these forums may show threads where people have had similar experiences & there may be a work around (e.g. using a different version of the exporter in Endnote, editing the file slightly, or making small changes to the Zotero translator).
  • The main advantage of RIS comes in making the types of changes noksagt mentions, as it's much easier to modify using search&replace.
  • The primary reason XML is recommended as a default is that it preserves any rich text markup in item titles (e.g., italics, bold, etc.). If you don't have any of that, you likely won't notice any difference between the two formats.
  • edited April 9, 2019
    The documentation recommends exporting from EndNote in xml format, but it does not (I'm using x9) indicate what should be specified in 'output style'. Not sure why that option isn't greyed out, but does it matter what we enter there? Any thoughts?
  • When you export a database in EndNote XML (or RIS) there is no relevant style. You are using a selected to export your database records _not_ some bibliographic style.
  • That's what I thought. And why I expected that option would be greyed out. But so ok, that confirms. I was just afraid that the reason why I am now already importing only 5600 items (and yes, sync is off) is already taking over an hour. But I guess patience is in order...
  • I'm afraid import into Zotero is quite slow, yes. There's been talk of speeding that up (and that will definitely happen), but I don't know how far advanced they are on that front.
  • I keep getting an error trying to do this (tried 2 times) - error 296911007. Can somebody please look into this?
  • [JavaScript Error: "out of memory"]
    You should try opening the file up in a text editor (e.g., Notepad) and breaking it into multiple files, and then importing those. (We'll be improving memory usage along with performance for imports in the not-too-distant future.)
  • Splitting isn't trivial with XML, though. Are you able to export smaller bits? Otherwise I can probably tell you what to change to split Endnote XML files.
  • (Oh, sorry, I thought this was RIS.)
  • I have put this issue on the back burner for now. But thanks for looking into this. And I guess I could always export smaller batches from Endnote separately. Are there any rules of thumb for how big these can be for what amount of memory?
  • Nothing super reliable (depends on length of the XML entries and computer memory) but 2k are typically fine on a modern computer.
  • We also have an open issue for reducing the memory usage of EndNote XML import.
  • Any word/suggestions on improving import performance (also for larger collections)?
  • Not looking forward to having in import 21k items from EndNote into Zotero :(. Still no changes/new 'lessons learned' on this front before I start?
  • Nothing new, no, sorry
  • Sigh. I'm getting about 30 per minute. That was 2 hours ago. That means it would have taken over 12 hours. And it looks like it's frozen already. I'm not touching it yet, though - will let it run until noon tomorrow. But it's so frustrating to think that the ris I exported from Publish or Perish took less than 2 minutes to import into EndNote, but that it will now take 12 (!!) hours to import into Zotero. IF it will even work at all ...
  • If you're using RIS, you should definitely split it up into chunks as described above.
  • @sdspieg: Try the latest Zotero beta, which should dramatically speed up some imports.
  • @dstillman - will do. Because after 12 hours, Zotero was still stuck. And had only downloaded 1754 items. Retrying it now in the beta, with debugging enabled. Will report back.
  • I'd suspect that enabling debugging might actually slow this down, so I wouldn't. Debug that runs for more than a couple of minutes is typically useless anyway.
  • edited April 10, 2020
    UPD - the first time I tried with the beta version, it did import things significantly faster, but it still crashed after 18,207 items. I restarted it this evening, with debugging off, and it ran for about 3 hours, then crashed, but I still got 21,431 items of the 21,579 I had in EndNote. So that's really 4 times faster, which is a LOT of progress, even if it is still a lot slower that the few minutes it took to get the PoP export from Google Scholar into EndNote. But so a GREAT many thanks to @dstillman (a quick look at Github suggests that he has heroically been making all of the commits since a few months all by himself!)
  • I had imported these items into my own library, and would now like to get them into a group library. Any suggestions on how best to do this? I tried dragging them, but that didn't work. [Also I get an error (Report ID 42967530) - not sure whether that's related. If you want me to open another thread for this, I'd be happy to]
  • edited April 10, 2020
    [JavaScript Error: "NS_ERROR_FAILURE: Failure arg 0 [mozIStorageResultSet.getNextRow]" {file: "resource://gre/modules/Sqlite.jsm" line: 768}]
    [JavaScript Error: "Failure arg 1 [mozIStorageAsyncStatement.executeAsync]" {file: "resource://gre/modules/Sqlite.jsm" line: 764}]
    Restart Zotero and try again. Dragging should work fine, and you're getting a weird error.
  • We'll look into the import crashes you were seeing.

    We should also be able to significantly improve import performance further, but that may not happen for a while.
  • Update: all items did end up in the Group library now. Thanks much @danstillman
Sign In or Register to comment.