How to erase "full text" without deleting the entry

Hello,

I appear to have been accidentally downloading the "fulltext" pdf versions of journal articles. I have no interest in doing so, because I already store them under my own indexing system. I also have no interest in the "snapshots".

When I attempt to delete the "fulltext" from an entry, Zotero annoyingly throws the entire entry into the trash. It seems that it's possible to correctly delete the "fulltext" from within the trash, but this is wasting the time to which I've gone to organize the entries into folders, etc.

It's also possible to erase all of the "fulltext" via the "storage" folder on my hard drive.

But there must be some way to avoid this situation in the first place. I've restarted Zotero, but this didn't help.

Thoughts?

Thanks

Fenton
  • Actually it's not possible to erase the "full text" from within the trash.
  • This is easy to fix. Do an Advamced Search for ‘item type’ ‘is’ ‘attachment’ and make a Saved Search. Then, type Ctrl/Cmd+A, right click, and choose move to trash. This will delete the attachments but not the top level items.
  • Thanks for your response.

    However, we may have a misunderstanding. If I carry out an advanced search as:
    "Attachment File type" -> "is" -> "pdf" -> "search subcollections"
    or
    "Item Type" -> "is" -> "attachment" -> "search subcollections"

    Of course one creates a search which identifies which entries contain pdf files. But still:it's only possible to edit the entry after leaving the "Advanced Search" dialogue. That means there is no change in the results of deleting the pdf file. It still throws the entire entry into the trash. I've confirmed that there is no difference in the end result.

    It also does noting about those "snapshot" files. If I even locate the unwanted version of the pdf file on my hard drive, and "hand-delete" it, then the "snapshot" file will - if possible- find a new version of the pdf file on the internet and download it.
  • I work with patent files and journal files.
    I delete the sub-folders which contain the pdf file then that will erase the journal pdfs. However, Zotero then finds any open-access patents and journals on the internet....and downloads them. Back to square #1
  • edited 5 days ago
    No, you are misunderstanding Zotero’s behavior. When you search for “type is attachment” the results will only be they attachments, not the top level results (those will be shown with gray text). If you make a Saved Search, you can then select all and delete the attachments while retaining the top level items.

    Deleting the files in your computer’s file system directly will not delete them in the Zotero library.
  • I'm sorry but this is clearly not working.

    Searching “Item Type” -> “is” -> “attachment”, with none of the three boxes selected gives everything (entries and sub-entries)
    Searching “Item Type” -> “is” -> “attachment”, with the “show only top-level items” box selected gives nothing.
    Searching “Item Type” -> “is” -> “attachment”, with the “search sub-collection box” select-ed gives everything (entries and sub-entries) gives everything (entries and sub-entries)
    Searching “Item Type” -> “is” -> “attachment”, with the “include parent and child items” box selected gives everything (entries and sub-entries) gives everything (entries and sub-entries)
    Searching “Item Type” -> “is” -> “attachment”, with both “search sub-collection" and “include parent and child items” boxes gives everything.
    Searching “Item Type” -> “is” -> “attachment”, with both “search sub-collection" and “show only top-level items” gives nothing.

    “Attachment file type” -> “is” -> “pdf”, no boxes selected gives everything
    “Attachment file type” -> “is” -> “pdf”, selecting “show only top-level items” gives nothing
    “Attachment file type” -> “is” -> “pdf”, selecting “include parent and child items of match-ing items" gives everything
    “Attachment file type” -> “is” -> “pdf", selecting "search sub collections" gives everything.

    “Attachment file type” -> “is” -> “document”, no boxes selected, gives nothing

    https://forums.zotero.org/discussion/72752/how-to-erase-full-text-without-deleting-the-entry?#
    The two options are either:
    “Attachment file type” -> “pdf”
    “Item type” -> “journal article”
    When you write “type is attachment”, which one of those two choices do you mean? Are you referring to the PC or the Mac version of Zotero? I'm working on a Mac.
    https://forums.zotero.org/discussion/72752/how-to-erase-full-text-without-deleting-the-entry?#
  • Please trust that the people advising you here know what they're talking about. You're just not doing what bwiernik tells you to.
    Searching “Item Type” -> “is” -> “attachment”, with none of the three boxes selected gives everything (entries and sub-entries)
    That's not right. It _shows_ everything, everything but the attachments is greyed out. If you create a saved search, open the saved search and select all (cmd+a), you'll note that only the attachments are selected, which you can then delete using right-click (ctrl+click) --> move to trash.
  • I can confirm that the described search does allow to select only the pdfs. When I do so, and then "move item to trash" it then moves the complete entries to the trash.

    However when I move to the trash folder, and repeat the selection process, only the pdf files are again selected. Repeating the 'delete' action on them, followed by undeleting the original entries then ultimately removes the pdfs.

    Independently, I've also moved all doi. and url links from the "info" pane (storing them e.g. as a note). This circumvents the auto-click property, whereby Zotero tries to download the same old file. This is especially helpful for patent literature, since patents are never behind paywalls. Maybe that could also deal with the original pdf issue?

    What do I know, maybe there are some issues here which could be addressed in future versions.
  • This circumvents the auto-click property, whereby Zotero tries to download the same old file.
    This is based on a misunderstanding. Unless you're running the Zotero beta, Zotero does not have the ability to automatically download PDFs for existing items from anywhere on the web, OA or not.


    You can disable the attaching files/PDFs on import in the general tab of the Zotero preferences.
  • edited 4 days ago
    Also just to clarify:
    When I do so, and then "move item to trash" it then moves the complete entries to the trash.
    it really doesn't move the items to the trash, it just shows the context of the attachments in the trash. Notice the greyed out/not greyed out distinction. Just emptying the trash would have been sufficient. If you actually move an item to your trash, it disappears from My Library.
Sign In or Register to comment.