problem with moving from Mendeley to Zotero

I have Mendeley 19 that crashes upon opening and I would like to move to Zotero. I tried importing the Mendeley library from Zotero desktop but it is failing. I've heard that there are encryption problems with this version of Mendeley. Does anybody has a solution how to import papers from Mendeley to Zotero keeping folder structure? Thank you for your help in advance.
  • I tried that but unfortunately does not work.
  • If something isn’t working, you will need to describe exactly what you are doing and what is happening. It is really hard to help if all we have to go on is “does not work”.
  • I tried everything described in this document. I can't import mendeley as I'm getting an error: "the selected database cannot be read", i tried finding the folder you suggested in the Mendeley folder but it does not exit, I'm downloaded Mendeley 1.18 but it still crashes on opening. I've emailed Mendeley but they've just replied we are working on a crashing issue and it has been a week can't use Mendeley and that 's why I'm switching to Zotero but it seems that I can't import my Mendeley library.
  • If you have updated to Mendeley 1.19, then Zotero won’t be able to immediately read that database, as it has been encrypted. If you can’t get 1.18 to work and you can use Linux, then you can try to use these steps https://eighty-twenty.org/2018/06/13/mendeley-encrypted-db
  • thank you for pointing me out to this article. unfortunately i don't have a sqlite
    like tonygarnockjones@gmail.com@www.mendeley.com.sqlite (of course replaced with my email addess) in my mendeley directory, so i can't copy it and consequently do what is written in this tutorial. any other ideas? thank you for your help
  • Don't worry about that eight-twenty.org page — that's not for general audiences. You can just follow the instructions that fcheslack linked to above, which include moving your current Mendeley data directory out of the way and resyncing with 1.18 (with the unavoidable caveats described there).

    If you're still having trouble, cite each line you're following and say what happened after each step, and we'll tell you where you went astray.
  • But if 1.18 crashes, how will they sync it?
  • From what I've seen, 1.18 crashes when the encrypted 1.19 database is still in place.
  • i moved out 1.19 database, deleted Mendeley 1.19, downloaded Mendeley 1.18 and then tried to open Mendeley 1.18 and it crashes on opening. any ideas what i could try now?
  • Did you move the entire data directory?
  • Can you try to install Mendeley on a different computer?
  • If you did move the whole data directory, what was the full path of the directory you moved? (You can X out your username.)
  • I moved the Mendeley_Desktop folder. The directory was in user/Documents/Mendeley_Desktop. I could try on a different computer.
  • That's not your data directory, so you should move that back. That's just where your PDFs are. Our instructions link to Mendeley's support page for locating your data directory.
  • i've probably tried moving my data directory before as email@www.mendeley.com.sqlite file was located in a different folder where it apparently should be. i moved it now to a desktop and my mendeley is still crashing

  • edited 2 days ago
    Well, we obviously can't fix Mendeley — we can just tell you that as far as we know this happens in 1.18 when there's still the 1.19 database.

    So I would try locating that folder again and making a note of the full path. Then try moving it out of the way and starting Mendeley again. If it's still crashing after that, let us know the exact path of the folder you moved.

    If all else fails, you can try on another computer, as bwiernik suggests.
Sign In or Register to comment.