Citation Issue with MS Word 16.16 (180705) and macOS 10.14 Beta (18A326h)


Every time I try to Add/Edit Citation in Microsoft Word, the usual red box does not show up and the Zotero freezes resulting in SPINNING RAINBOW CURSOR. What do you think?

Please let me know if you need further information. I think probably, I’m not able to provide a debug error as the application crashes during the process.
  • Hey!

    I have the exact same problem and was searching the forums without luck - Zotero always crashes two seconds after i use any button from the word plugin. Reinstalling the plugin didn't work.

    It worked definitely in the first two betas of Mojave and there was no Word update and i even tried reinstalling Word and Zotero, both with the newest betas. Didn't work :/
    Is this problem related to the macOS beta?
  • edited July 11, 2018
    We do not really have any good news on this. On the current Mojave Beta a lot of inter-app integrations are broken (e.g. XCode and Finder, or controlling any app using Apple Script via the Terminal). Zotero relies on this mechanism too, you should get a prompt saying that Zotero is trying to control Word, such as in this macOS Mojave Apple Events Sandboxing article, but it doesn't show up while Zotero gets frozen, waiting for permissions from Word. We expect Apple to address this in a subsequent Beta.
  • Thanks for your reply!
    It's good to know that this is a problem on Apples Side. Because I switched to Zotero from Endnote as I noticed, that it was not working with Beta 1 and I instantly preferred Zotero. I was just confused, because I'm sure it was working on Beta 1&2 and thought it might be a Word/Zotero-Problem. So here's to waiting for Beta 4. Thanks for the closure!
  • Just a small update: the Zotero-Plugin in Word is now working on the latest Beta (Developer Beta 4; Build 18A336e). Seems like Apple recognized the problem and fixed it. Will update if a future Beta breaks it again.
  • I can confirm it now works fine. Same build 18A336e
  • After the latest updates it’s now working fine.
Sign In or Register to comment.