Zotero standalone does not start in Debian

The software crashes at the beginning and the following alert appears:

There was an error starting Zotero.


The machine runs a Debian 4.16.12-1 64 bit, Buster release and zotero is update at the last version.
Any ideas?

  • Nobody can't help me?

    It is a pity, as I am also a paying user...

  • @adamsmith Do you have any experience with Debian?

    (It’s not a question of ignoring you or you paying for storage or not, there are just very few people who can help with Debian setups, and it’s possible they missed your message.)
  • Thank you bwiernik. I am a Debian user since 2005... and I have been used to tweak many software to make them working with debian.
    For this case of Zotero, I tried several things with no success, and the thing that I am paying for the storage is not to say that they should give me special attention, but just that maybe that it is worthless for me to pay for something that I cannot use.

  • I'm not sure we'll be able to help, but see Reporting Startup Errors for providing more details on the error.
  • I have the same problem in Debian Stretch. How can I contribute to solve this?
  • I just installed the unofficial packaged version (official binaries, just the packaging is not done by Zotero) from https://github.com/retorquere/zotero-deb on a freshly installed stretch VM, and that started without issue for me.
  • Buster doesn't boot in my VirtualBox installation so I cannot test.
  • I used emilianoeheyns solution for my laptop and it worked. Thank you!
  • Note that there's absolutely nothing special about this zotero version - I just download zotero and stick it in a Deb file, which puts files in the right places. This makes it easy to install but does not explain why this version runs on your system and a regular download does not.
  • It seems like the version you uploaded is a later one 5.0.58
    And the one in the Debian repository is Maybe this has something to do with it?
  • Yes, that would explain everything, but with the current talk in this thread, the zotero devs will likely think you were installing the latest version manually. There is no official packaged version, so that is not what they'll assume you have. I'm keeping my repo updated until zotero starts hosting official debs.
  • I had the same problem in Ubuntu, but other numbers at the end of the line.

    There was an error starting Zotero.

    I'll tell you what is exactly my problem and how can I manage it:
    I have three partitions in my PC: one with Windows 10, one with Ubuntu and one "extFAT" for sharing between them (because I have Zotero in windows and ubuntu with the same file archive). It works fine but sometimes the last partition doesn't auto-initialize well and Ubuntu can read but can't write. In this case, when I open Zotero it brings me the error.

    The only thing I can do when this problem occurs is to initialize manually the partitions.

    Maybe you have a similar problem.

Sign In or Register to comment.