Zotero experienced an error updating your document.The remote procedure call failed (insertFieldRaw)

When trying to insert or reinsert a citation, I keep getting this message after Word documents, into which I'm trying to insert, just crash.

I'm using latest versions of Word and Zotero - both of which I've used for a long time.

Any suggestions, please?
  • Does this happen in a new document, too?

    If it doesn't, run through https://www.zotero.org/support/word_processor_plugin_troubleshooting#debugging_broken_documents

    The most likely causes for this are citations in image captions or after the bibliography.
  • Thanks. Copying into new document seems to work.
  • Report ID. 1648990775

    The Word document crashing problem has now returned so I've just sent in this Report.

    Though I've copied documents into a new document and done this several times, each time I try to load a bibliography or a citation, the Word document just crashes.

    I have changed styles, split the document into sections and Accepted All Tracked Changes and carried out suggestions in the link you sent.

    Advice, please.
  • Which exact Word, operating system and Zotero version?
  • Office 365 Word. Windows 10 Pro and latest downloaded version of Zotero.
  • Seems to be Zotero 5.0.48.
  • What exact version of Word (e.g., 1805)? Find this in the Account section of the File menu, under About Word on the right.
  • Yes. It's 1805 (Build 9330.2087 Click-to-Run)
  • Just wondered whether you had any further thoughts since I posted details of my Word version two days ago, since I'm anxious to make progress?
  • You’ve done step 8 here to ensure that you don’t have a corrupt citation somewhere?
  • Thanks for this. Yes. I've tried all of that, including copying to a new document and splitting the document into two halves to isolate the problem. But Word keeps crashing. Is this a problem for a particular Word version?
  • Look forward to hearing from you. Thank you.
  • This is definitely not a widespread issue.

    @adomasven Any ideas?
  • I'm not trying to be difficult. Back in January, your colleague showed me how to remove duplicates and wrong citations, using Alt and F9. So I can do all that. But, irrespective of whether there are problem citations or not, each time I try to insert a new citation or bibliography, Word just crashes. I'm now at the stage where before each step I take, I must save in Word.
  • Since you say that it doesn’t crash in a new empty document, I would recommend trying to copy one paragraph at a time into a document and then bringing up the Zotero citation dialogue to see if it crashes. I suspect you will find one or several corrupt citations are the cause of the problem.

    I’m not sure what you are describing about duplicates and Alt+F9. Can you elaborate? You should defiantly not manually change Zotero field codes, and doing say would likely be the cause here.
  • Will follow what you recommend about copying into Word document in stages, to identify whether any corrupt citations.

    Recurring duplicates in bibliographies was the original issue in January, which caused your colleague to recommend looking at field codes using Alt and F9. Following his advice, if the Zotero field code doesn't produce a reference in Zotero, I then delete that citation and try to reinsert. In no case have I tried to alter field codes. It's when I try to insert a new citation that Word keeps crashing.
Sign In or Register to comment.