zotero 5 and SSL certificate error


I'm behind a corporate reverse proxy that uses custom CA. I understand that a solution is to copy cert_override.txt and cert8.db to zotero profile directory. But the newer Firefox only provides cert9.db and it's possible to convert this to the older format. I wonder if there is a more flexible solution on the horizon. I suspect this causes some PDF downloads to fail (probably those via https). I imagine that any development to address this would be greatly appreciated by many.

  • We'll be switching to a Firefox 60-based version before August (when Firefox 52 ESR goes EOL), so the newer format should work with that. That should be in beta fairly soon.

    Longer-term, we'll be switching to a new platform (Electron) and should be able to offer better support for this.

    Since it's still possible to generate these in Firefox, I don't think we'll be spending time on this before then.
  • @cuigl: you mentioned, that it is possible to convert the cert9.db (from Firefox 60.0) to a cert8.db file, needed for zotero5.

    Can you give me more detailed help, how to do that?

  • Can anyone else give me a more detailed help/answer on my question above?

  • @SiGi sorry for the delay. My understanding is that it is possible to convert (using certutil) cert9.db to cert8.db via an intermediate format, but I've never tried it myself. I'm hoping that the developers will come up with a solution very soon!
  • @ciugl thanks for the answer. Perhaps I will have a look on certutil, if it's not to complicated.

  • I have solved the cert9.db/key4.db problem of firefox60, by installing an older firefox (52-ESR) version, importing my special organisations certificates and using the in firefox52 gernerated cert8.db, key3.db Files (from the profile) for zotero5-profile.

    It works so far.
Sign In or Register to comment.