Word plugin problem

I can't find this problem in existing threads: Recently the Word plugin stopped inserting references into files (Office 97). When I click the "Insert citation" button in Word it comes up with the dialog box and loads my Zotero references; but when I select a reference nothing happens. If I show the edit box nothing is there. There is no error message. I can see the {Citation} placeholder in the document, but when I close the window it disappears.
This originally happened with Zotero 1.0. I decided to upgrade to 2.0 partially in the hopes it would solve the problem. I installed the new plugin (1.0b4) as required; but the problem remained in exactly the same form.
I then thought this could be a Word problem, so I reinstalled Office from the original disk. No dice. I've tried multiple documents, to no avail.
I've tried uninstalling the plugin and reinstalling, and putting it in the Templates folder rather than the START folder (where it was originally put). None of this works.
The fact that the Zotero pane shows the list, but the Editor doesn't show the esected citation, makes me think it's a Zotero problem rather than a Word problem. On the other hand, the fact that it carried over from Zotero 1.0 to 2.0 (with the new plugin) makes me think it might be a Word problem.
So now I'm at a loss! Please help!


I've done some further sleuthing: If I enter something in the "prefix" or "suffix" or "page" boxes, that does show up in the editor and does get transferred properly into the Word document. So the problem lies somewhere between the list of references in the "insert reference" popup and the editor in that same popup. Could it have somehow lost the templates that tell it how to transform a Zotero reference into a citation in the document?
The transformations do work within Zotero: if I "create bibliography from selected item" in Zotero, it formats the output just fine. It just won't do it in the Word plugin.
I thought I had solved the problem by clicking on Reset Translators and Styles in the Advanced pane of the Zotero prefs. But (see next entry) it has come back again.
  • I made a few comments in your first thread. In particular: Have you tried changing bibliography styles? Do both the citation and the entry in the bibliography appear to be missing?
  • Now to complicate life further, it's stopped working again, and now resetting the translators and styles no longer works!
    Yes, I have walked through the troubleshooting steps -- note that I do not receive an error message, and the troubleshooting scenarios generally assume one. I have tried changing bibliography styles. Nothing is entered into the document, so no bibliography can be created.
    I will keep trying things -- something must be workable since I got it to work that once!
Sign In or Register to comment.