URGENT! zotero error "you must place the cursor in a zotero citation to edit it"

I've reviewed the previous posts on this issue and don't see a ready solution.

THIS IS URGENT, I am currently writing my PhD Qualification Exam, this is a time exam, I have written 3 of 4 questions without problem but now have this error and can't use Zotero (can't insert new, edit, add Bib).

Any suggestions or workarounds for temporary fixes are welcomed as well so I can at least get citations in and reference list inserted.
  • Does it work correctly in a new document?
  • No, but I found a workaround. No matter what I did, in that document or any other, I would get that error, which is strange because I don't understand how it could "follow" from one document to another, but I even closed everything, restarted computer, opened fresh document, but same error.

    Workaround: in the document that caused the error originally, copy all text (ctrl + a) and delete. Paste as plain text. This removes all formatting and all Zotero code hidden in the document. That fixed it, I was then able to go back through and one-by-one "Add/Edit Citation" for each reference, since they were still there as plain text.

    So the problem seems to be a corrupted citation, but somehow it corrupts Zotero and not just the document? I have a theory about how it may have happened but don't have time to troubleshoot at the moment--but it was the worst time for this to happen!
Sign In or Register to comment.