Mass tagging

It would save _a lot_ of time to be able to select a bunch of references and right-click (or click on the tag selector) and tag them all at once.

Is this possible?
  • Hah - I have the exact same request two minutes later...
  • Select items, drag to tag selector. Use "Display all tags [in this library]" if you're within a collection and want to apply a tag not yet applied to any other items in the collection.
  • edited May 26, 2009
    Thanks :) I actually asked this same question two years ago and forgot. D'oh.

    EDIT: A more obvious interface wouldn't go amiss though.
  • Thanks. This should be in documentation:
  • Robert: It is. It's explained on that page.
  • > You can also assign tags to multiple items at once by dragging items from the items
    > pane onto tags in the tag selector.

    I can't drag items to a tag. I tried single items, several items, left button down, middle button down... no luck.

    using 2.0b6.5
  • edited September 22, 2009
    1) Upgrade to 2.0b7.1.

    2) You'll need to provide a bit more information. "I can't drag items to a tag" doesn't tell us much.
  • > You can also assign tags to multiple items at once by dragging items from the items
    > pane onto tags in the tag selector.

    This doesn't work for me either. Using 2.0b7.4, in Firefox 3.5.7, on Vista Ultimate 64-bit SP2.

    Steps to reproduce (easy, happens all the time):
    Click on any item in library (whether it has tags on it already or not), and drag it to a non-any tag in the tag selector (black or gray [if "display all tags" is on]; doesn't matter).
    It does not add that tag to that item. Never works.

    I have no idea what I'm doing wrong. I'm just following the basic instructions on how to do this, and it simply doesn't work on my machine.

    Note: the error log contained this message for every time I tried to do it and it failed:

    [JavaScript Error: "uncaught exception: Cannot add invalid tag 93-13 in Zotero.Item.addTagByID()"]

    This happened no matter what tag I tried to drag to, though, and they are all tags which can validly be applied by clicking on the Add button in the Tags tab for an item in my Library.

    Update: I just realized this is a result of an old unfixed bug:

    That is probably what is causing iphan's problem, too. I just verified that it works for me if I drag to a tag name that I'd created myself, but not for when I drag to a tag that was automatically created.
  • I am also experiencing this problem. I cannot drag and drop any entry (batch or single) to any tag, whether automatically or user created, whether in the entire library or just the subcollection. I'm not getting any sort of an error when I try to do this. I've tried uninstalling and reinstalling multiple times to no avail.
    I'm using Mozilla 3.6.3, Zotero 2.0.3 on Windows XP Professional V. 2002 Service Pack 3.
    All suggestions welcome!
  • where exactly are you dragging the items? To the left or right pane?
  • To the left pane.
Sign In or Register to comment.