Problems exporting collections

I'm exporting from Zotero for the first time. I tried to export two collections to a CSV. One was at the third level in the hierarchy of collections; the other was at the fifth level. I experienced two problems early on:

(1) For the first collection, Zotero exported most but not all of the records: 640 of 673 references. I can't figure out why some references didn't get included. Note that I'm opening the CSV file in Excel.

(2) The export for the second collection showed as empty (except for the headings) when I opened the CSV file in Excel. This collection is a sub-sub-collection of the first. The only possible explanation I can think of is that Zotero perhaps can't properly export collections too deep into the hierarchy of collections.

Any ideas anybody?
  • Are you using recursive collections via the hidden preference?

    Note that you can also just do select all and right-click --> Export selected items
  • Thank you, Adam. Exporting items worked just right. I'm guessing I should never need to export collections if I can't get that feature to work right.

    I don't know what you mean by "using recursive collections via the hidden preference," so probably I'm not doing that. How would I find out?
  • You'd have had to change a hidden preference with that name ( ), so yes, the fact that you don't know what I mean does mean you're not using them.

    This is still a bug, clearly, and I suspect you're exactly right as to its cause being deeply nested collections.
Sign In or Register to comment.