Refreshing keeps reverting changes

I've learned how to modify bibliography without zotero messing it up for me.
But now the problem are the cites, when I modify them and then refresh it prompts me, do you want to keep your changes, i press yes on all of them and only the last cite keeps my modifications, all the rest revert back and delete my modifications.
Tried to search this forum but cant really find anything that helps, this almost seems like a bug.
  • I’ve never seen that behavior before. @adomasven would know what information to ask for to figure that out.

    That said, you should not modify citations directly in word, but instead use Zotero’s Prefix, suffix, and page number fields:
    https://www.zotero.org/support/word_processor_plugin_usage#customizing_cites
  • Thanks, that helps.
    Never really hovered with my mouse over those, so didn't know this feature.
  • Could you submit a Report ID?
    What word processor are you using?
  • edited 6 days ago
    Sorry but i've restarted zotero since the problem.
    I have also edited every cite through zotero now, so its not messing things up anymore when updating/refreshing.
    I have tried adding a couple of cites now and editing them. While not deleting page numbers anymore, it does not like when I do this for example:
    as stated by (blabla 2014) - i edit it manually to:
    as stated by blabla (2014), when refreshing it asks me if i want to keep the changes, i press yes and it reverts back to (blabla 2014)
  • edited 6 days ago
    I think that's it, because I used to edit manually, I used to change the brackets to only revolve around the year and page numbers so if I had (blabla 2014) and changed it to blabla (2014, pp.1-5).
    Upon refreshing it it just goes back to (blabla 2014)

    Can I cite somehow where the brackets are only around the year and pp? It seems that zotero wants to put brackets around the whole highlighted field at all times.
  • You should still submit a Report ID. Pressing "yes" in the dialog should not remove your changes, so this is a bug you are describing (although I cannot reproduce it myself, which is why the Report ID is needed). What version and what word processor are you using?

    You can use the "suppress author" checkbox in the citation editor to achieve what you are trying above without having to manually modify the citations. However, you should still answer the questions above, since if there is a genuine bug in Zotero, we need to figure out what's causing it and fix it.
  • edited 5 days ago
    Supress author removes the author so I need to look it up and write blabla et al. my self, which isn't a big deal but still, i'd rather just remove/move the bracket.
    Report ID 882471361
    Word 16.0.8431.2110 64bit

    I can recreate the problem every single time
  • What you are asking for has been asked many times, but the feature is hard to implement properly due to many reasons, including grammar differences of different languages.

    I'll update this thread once I have time to take a look at the refresh bug with Windows Word, but LibreOffice behaves correctly.
  • @Viliuss can you reproduce this in a new doc? What citation style are you using?
  • I can, every time.
    Anglia Ruskin University - Harvard
Sign In or Register to comment.