Unwanted capital letters following Circumflex in article/book titles of Zotero-generated citations

I work with foreign language (Turkish and Ottoman Turkish) articles and books, many of which use the circumflex over vowels (e.g. â, î)

When the title of a work has a circumflex, Zotero capitalizes the letter following the vowel with a circumflex.

For example, check out this citation I copied from my Mac Word 2011 document:

Akot, “Seyyid Sibğatullah ArvâSî (ö. 1287/1870) ve Bazı Tasavvufî Kavramlara Yaklaşımı [Seyyid Sabatullah Arvasi and His Approach to Some Mystical Concepts],” 253.

The Zotero-generated citation capitalizes the "S" in Arvâsî (to make ArvâSî" even though the "s" is lowercase in my Zotero source information entry.

Is there a way prevent the citation generated in Word from capitalizing these letters following vowels with a circumflex?

  • You can remove automatic title casing for an item entirely by putting tr-TR into the "Language" field.

    @fbennett I can reproduce this. I vaguely remember it had come up before and thought it was related to character composition, but I get this regardless of how the â is composed.
  • @adamsmith A straight processor test fixture with "Seyyid sibğatullah arvâsî" set as title and with a text-case="title" attribute renders the string as "Seyyid Sibğatullah Arvâsî". Same result with (rather dated) JS processors from webkit, mozilla, and Rhino.

    The difference could be due to one of three things:
    (1) an anomaly in the JS processor in FF 51 (would be surprising, but Unicode is hard);
    (2) some change to the string in Zotero (that would be a little more surprising); or
    (3) some difference in citeproc-js runtime settings that affects things (which also seems unlikely, but I'll check this first).

    Will take a good look at it, but it's a puzzler.
  • @mghaz, @adamsmith What style produces that result for you?
  • edited May 4, 2018
    I tried with Chicago author-date (with locale defaulting to en-US). Can you not replicate this in Zotero?

    edit: and just confirmed with the simplified three-word title from your post which renders as Seyyid Sibğatullah ArvâSî ) testing on the latest beta, 5.0.47-beta.1+b8e0c3f7e
  • edited May 4, 2018
    Thanks to both of you.

    As @adamsmith suggested I tried putting tr-TR into the "Language" field and it seems to work.

    @fbennett I was (and still am) using Chicago (full note)
  • edited May 4, 2018
    Also in case you need to know as well...

    Language: English (US)
    Display Citations As: Footnotes
    Store Citations as: Fields
    Automatically update citations: checked

    Finally, just in case this complicates things, I am using Mac OS X Turkish QWERTY keyboard to enter the circumflex (alt+h) over vowels like û, â, and î.
  • Sorry - I can replicate in Zotero, and in Juris-M. But I can't get it to fail when running the processor on its own, with any of those three JS engines. I'll have to do the debugging inside the Zotero or Juris-M client. It will be a little awkward and might take a few days, but I'm also curious why this is happening. Will keep after it.
  • Okay, this is fixed in citeproc-js tag 1.1.206. I had used actual en-dash and em-dash in a regular expression (to remove markup and punctuation from the string before title-casing). That worked in the earlier JS implementations, but for >reasons< it had this effect in the more recent JS engine in Firefox. Using the escaped forms (\u2013 and \u2014) solves the problem.

    @mghaz The revised processor will be included in a future release of Zotero. If you need a fix immediately, you can download the Propachi plugin and install it in the Zotero client as a temporary repair. (In that case, you should remove the plugin when the next Zotero update appears.)
Sign In or Register to comment.