Available for beta testing: Google Docs integration

  • I switched back and indeed, this solves the problem.
    Thanks for the very fast and professional help. And also thanks for Zotero, and for the Google Docs connector in particular. It is much appreciated!
  • Fixed in the beta version now.
  • Installed the new beta, and indeed, I see no problems.
  • I've been testing the connector (not collaboratively for now though) and was able to insert footnotes without any problems. However, when I want to generate bibliography, I get a pop-up window, saying "You must insert a citation to perform this operation". But the documents already contains citations. Would appreciate help with this. Thank you!
  • Which citation style?
  • (Khrystyna is part of our team) We typically use Chicago (Full note)
  • Works for me. Can you replicate this consistently or is this a one-time thing?
  • Thanks, sdsspieg, it is indeed Chicago (full note). I tried doing it several days in a row to test and just tried again - same thing. Thank you!
  • Could you say exactly what you're doing? E.g. do you insert the footnote with Google docs or using Zotero? How many footnotes?
  • I was testing the tool, hoping to be able to use it for work so it's been a few footnotes (up to 3). And I tried both ways but now I can't insert footnote, using Zotero menu at all. I'm getting the following error


    Zotero experienced an error updating your document.

    linkbubble is null"

  • Could you submit a Report ID from the Zotero Connector?

    Does it start working if you first hover over one of the Zotero citations before trying to insert?
  • Yes, if I select one item in a Zotero library, I get the red Zotero box, it takes a few minutes to find the item but then it does find and insert it. And when I click the bibliography option, it does generate it. I tried with one and two items, works well. Thank you! I've also submitted an error report, Report ID: 1572180299
  • I am using the plugin and it is working well. I chose a style Progress in Materials Sciences that numbers references. However, when adding a reference before a previously inserted reference, the references do not renumber properly, which does work in Libreoffice. Is there any setting that needs to be made? What happens how is that the new reference is given the last number, even if it appears at the beginning.
  • And clicking "Refresh" doesn't update the numbering?
  • edited September 27, 2018
    Zotero Connector preferences, advanced tab does not show any google docs integration option. Firefox is 62.0.2 and the Connector 5.0.41.
  • this is currently only available in the Connector beta. See first post of this thread for link.
  • @pbabin I can confirm that this is a bug. We will be looking to fix it soon, but it turns out to not be very easy. In the meantime you can click "Refresh" to update the numbering as suggested by adamsmith above.
  • Did I do something wrong with the installation?
    I followed the directions on a previous thread for debug report, and the Debug ID is D412941205.

    I haven't been able to add a citation, and running Zotero Connector 5.0.42beta2 with Firefox 62.0.3 on Desktop Windows 10 Pro.

    When I try to add a citation, I'm able to select the paper from the pop-up navigation, but after I hit enter on that things seem to go downhill. Sometimes, the editing fields for text and link appear on the google document, but when I hit reply I get "Zotero experienced an error updating your document. citation is undefined". Other times, it doesn't make it past the point where I search and select the document for the citation with a message of "Zotero experienced an error updating your document. rawCode is undefined"

    I tried different basic troubleshooting such as different citations in zotero, opening new google documents, closing and reopening the brower and zotero, restarting the computer and whatnot, removing the Zotero connector and reinstalling, but issues remain for me. Not sure if I'm not cut out for the beta stuff, but I'd really love to use the feature! Just simple stuff and a few citations here and there. Thanks for your help.
  • i have exactly the same experience as above
    using Laptop with Windows 10 Pro
    firefox 62.0.3 (64 bit)
    Zotero Connector 5.0.42beta2
  • @Poriann, @wsetyonugroho What version of Zotero are you running? Which citation style? Could you submit a Report ID from Zotero?
  • @adomasven I’m having the same problem as Poriann describes where I can find my reference in the pop up, but when I press enter I get “Zotero experienced an error updating your document. rawCode is undefined"

    I’m running Firefox 62.0.3, Zotero 5.0.56 beta 22.+1b9811c31 and Zotero Connector 5.0.42beta2 on macOS 10.14
  • @nskg Could you submit a Report ID from both the Connector and Zotero client?
  • @adomasven Sorry for not reporting them. Here you go!

    Zotero report id: 574354313
    Connectorreport id : 1813988071
  • @nskg Which citation style are you using? Does it start working if you refresh the document tab?
  • @adomasven Im using american chemical society (The default i think)

    When I press the add citation button i see a link pup up where i want to add the citation, It quickly changes to the text "{processing}" and then disappears (even if I dont do anything). see https://www.dropbox.com/s/usm3puloaeq2d0p/Screen Recording 2018-10-10 at 10.14.33.mov?dl=0
  • The {Processing} appearing and disappearing is not a bug. You should not touch the document while trying to add a citation. If you proceed normally to add a citation, do you get an error?
  • @adomasven yes i get the error even if i just try to add citation right away, no touching the document.
  • @nskg Does it work in a new document? If it does, could you produce a Debug ID from Zotero for a citation attempt?

    1. In the Zotero Help menu, go to Debug Output Logging and select Enable.
    2. In Google Docs attempt to add a citation with Zotero, until you reach the failure state.
    3. Before doing anything else, return to Zotero Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • @adomasven
    my zotero is 5.0.55

    debug id D313170348
  • @wsetyonugroho: That’s from the connector. Follow the steps Adomas provided to generate a Debug ID from Zotero (and make sure you’ve upgraded to Zotero 5.0.56 first).
This discussion has been closed.