[SOLVED] Zotero Restricting Files

edited April 16, 2018
Hi Guys,

Zotero is restricting my pdf attachments, so that when I annotate, it forces me to save a new copy of the file, and attach it to the parent item once I've finished annotating.

I use standalone. This happens regardless of whether the pdf has been picked up from the source by the Chrome plugin, or if I manually upload the file from my computer (a file that is certainly not restricted in the first instance).

I've searched the forums, and there have been old posts where commenters have said this is due to the setting on the user's computer, but no info on how to update this.

I use both a Mac and a PC (synced). Would welcome any help you could offer.

TIA :-)
  • Zotero doesn't restrict file editing. What you are seeing would be caused by either your operating system (if you have your Zotero data saved in an un-editable place) or by your PDF program (e.g., Adobe may default to try to save PDFs to their cloud service).

    What version of Zotero are you using, and what exactly is the error message you are receiving? Do you have the issue on both Mac and PC?
  • The files are saved in the main 'Document' file on my hard drive, so if it's an a uneditable place, I'm not too sure how that's happened.

    The issue has been presenting itself over the weekend on my Mac. I don't use it as often as I use my PC, and haven't annotated on my PC for a while, but I do recall it happening there (I'll check when I get into the office, today). However, it has happened to every file I tried to annotate on my Mac.

    The error message is:

    "The original document can't be changed, so a duplicate with your changes has been created."

    I sync my computers using box.com for storage (if that helps).
  • That error message is a Mac error message and typically due, indeed, to having files in a location that doesn't allow editing (if you google the error message you'll find dozens of threads on all sorts of Zotero-unrelated forums).
    What's the exact filepath these documents are under? (you can x out your username if you prefer)
  • edited April 15, 2018
    By getting the path name, I can see that the files are copied into a new location locally (which I didn't realise). So whilst I thought they were drawing from the location I saved the copies in (which isn't a restricted location), it's not.

    An example file path is listed below

    Macintosh HD > Users> xxxx > Library > Application support > Zotero > Profiles > 9ejlplbh.default > zotero > storage > KWSHN4KI

    The 'KWSHN4KI' is the folder for a particular file. After the 'storage' folder there area bunch of different folders that house files. Is this restricted?

    ps: just got to my PC and annotated one of the problem files - no issue. So it looks like this is just an issue for my Mac, as you noted.
  • yeah, you can't annotate files in Application support since High Sierra anymore -- Zotero should have moved the Zotero data directory to a different location with version 5 though -- which Zotero version are you using?
  • Version 4.09.
    I'll update tonight and see how I go.

    Thank you for the help! :-)
  • That worked. Thank you, greatly appreciated :-)
Sign In or Register to comment.