TypeError: this.registry.citationreg.citationById[c[0]] is undefined

This happened in a new document with only two other references in it when I tried to insert a third

report id: 1429477037

[JavaScript Error: "CSL error
TypeError: this.registry.citationreg.citationById[c[0]] is undefined
atarray citationsPre index 0, from citation at document position 2"]

version => 5.0.43, platform => Win32, oscpu => Windows NT 10.0; WOW64, locale => en-US, appName => Zotero, appVersion => 5.0.43, extensions => Zotero LibreOffice Integration (5.0.11.SA.5.0.43, extension), Zotero Word for Windows Integration (5.0.8.SA.5.0.43, extension), Shockwave Flash (, plugin)
  • Adomas will want that document sent to support@zotero.org if you don't mind.
  • Just a snippet of it that shows the error would be fine, as explained in Step 8 of Debugging Broken Documents.
  • crud, sorry, I unlinked the references and started again.
    Don't think this is the first time this has happened to me, though. Will see if I can reproduce it later, and if I do, will send a copy through.
  • I've run into "CSL error this.registry.citationreg.citationById[c[0]] is undefined" as well. It was while inserting a citation of a previously cited source into a document with over 100 references. It just came up with the error message. Closing and reopening the document solved it. Before doing that I deleted the reference list and tried re-creating the list. That also caused the error.

    It was with Zotero 5.0.65, Windows 10 Oct. 2018 update, and Word 365.

  • Closing and reopening the document solved it.
    On the one hand -- yay. On the other hand, that'll make troubleshooting this a mess (and explains some of the difficulties nailing this down in other threads). It's almost a textbook Heisenbug...
  • It's not yet clear what triggers this. I saw it myself a few days ago, while working with a student over a thesis document. I was happy to see it, because I thought I had steps to reproduce -- but going through the same steps later didn't trigger it. It will eventually be squashed, but we'll need a debug log that covers the triggering of the fault. I'm really curious to know how this happens in a document.
  • Don't know if this is relevant, but when it first happened I was in split window view.
  • How large was the document, citation-wise? In our case, on a Mac, there were about 150 citations, and my unsuccessful after-trials were in a small document. I'm wondering if it is some async thing that only kicks in, erratically, when there is a significant delay.
  • Over 100 references.
  • Had another "this.registry.citationreg.citationById[c[0]] is undefined" error in this document today, again while working in split view mode. This time I had copied a zotero citation to another location and was adding a second source to the citation.

    "Zotero experienced an error updating your document.
    CSL error
    TypeError: this.registry.citationreg.citationById[c[0]] is undefined
    citationID = ICcSEKcE
    noteIndex = 0
    atarray citationsPre index 0, from citation at document position 360"

    I exited the document without saving and was able to resume using zotero after reopening the document. I'll let you know if this takes place again.

    Office 365 Business, Windows 10 Version 1809, Zotero 5.0.65, 115 references
  • This can happen when a citation is opened for editing or insertion, in an open document, immediately after restarting Zotero, if the edit/insert is then cancelled. The next operation will throw this error, and restarting Zotero and refreshing citations will fix things. The cause has been identified by the developers, and the latest beta release has a fix for it that will appear in 5.0.66.
Sign In or Register to comment.