Lost italics in LibreOffice

Dear all,
Recently I have experienced a disturbing problem in Zotero, using Zotero Standalone with LibreOffice 5.4; style Chicago Full note (but also with Chicago Note)
Due to an unknown reason, lots of the references have lost italics. It affects titles of books and also journals. I do not know why, it does not affect the whole document, it starts in a certain reference and affect the rest of the document; sometimes it takes place after introducing a new reference in the middle of a chapter.
I have seen that in Word it is noted, but this is LibreOffice. The solution for Word is here:
https://www.zotero.org/support/kb/italics_in_word_bibliographies
But it does not work and they seem to be different, though maybe related problems.
Any help? Any user with the same problem?
It is very disgusting, because I am finishing the book.
Thank you much
Álvaro
  • Go into Zotero Preferences -> Cite -> Word Processors and reinstall the LibreOffice plugin, then refresh the citations in the document
  • Dear adomasven,
    I am going to do it. Even if I can insert references, when I go to Preferences -> Cite -> Word Processors I see that "LibreOffice plugin is not installed" (!). This suggests that your idea can be right. I check it and post if it works.
    Thank you very much.
    Álvaro
  • Dear adomasven,
    It works and it seems to be solved. Thank you so much. For an unknown reason, Zotero thought that the plugin was not installed (even if it was and I could add references) and it seems to have created the problems. If I do not give any piece of information, it means that the problem has been solved.
    Thank you so much
    Álvaro
  • Dear all,
    unfortunately, the error remains. I have uninstalled and installed again LibreOffice, Zotero and the plugins of LibreOffice and Mozilla, but the mistake remains.
    When I refresh, everything is OK, but for some unknown reason italics are lost in some entries.
    This is seriously disturbing at the end of a PhD. I would deeply thank any piece of help!
    Best wishes,
    Alvaro
  • Could you submit a Report ID?
  • Dear adomasven:
    The Report ID is 71619963.
    When I refresh everything, everything is fine. The problem arises when I insert a new citation: then, all the italics of Zotero in next references in the chapter disappear, and some of the previous as well. Suprisingly, the italics of the next chapter (using the Chapter tool of libreoffice) remain, so:
    - It is a bug but the chapter division works as a stop.
    - It takes place when I insert a new reference: it makes disappear all the italics that follow in the chapte and some of the previous ones.
    - It appears with Chicago Note and Chicago Full citation; I have not tried other styles
    - It appears after uninstalling LibreOffice, Zotero and the Plugins.

    Can it be something to do with Java? It is very disturbing now, at the end...
    Thank you and best wishes
    Álvaro
  • The Report ID you have provided is invalid. Could you submit another one? Can you reproduce this issue in a new document?
  • Dear adomasven:
    I have submit another one: it is nº 757620310. Is it correct now?
    Thank you so much!
  • Can you reproduce this issue in a new document? Are you storing your citations as Bookmarks or ReferenceMarks?
  • Yes, I can reproduce it.
    First I insert three references:
    Book a, italics correct.
    Book b, italics correct
    Article.
    Then I insert a third book, between both of them, and the italics of the subsequent book are lost:
    Book a, italics correct.
    Book c, italics correct.
    Book b, italics lost.
    Article.
    I have generated a Report ID of this example, which has only one line; its id is 387666463

    I store my citations as ReferenceMarks
  • Now I tried to update Java to the last version, but LibreOffice do not recognise it!
  • I managed to reproduce this problem. We will have a fix out soon. Sorry for the trouble. In the time being you can ensure your styling is correct across the document by changing the citation style to something else and then changing back (e.g. Chicago full note)
  • Thank you so much, adomasven. Your solution is what I will adopt. It seems that if I refresh and do not modify anything, italics remain OK. But the document is so, so large (1000 pages) that refreshing all takes time!
    Thank you! I look forward to seeing if there is a fixing solution
    Álvaro
  • @alvarocancela You can now try installing the Zotero Beta, which should fix the issue you were seeing. We will update when the fix is available in the stable release.
  • Dear adomasven
    This is incredible! Thank you for such a fast, polite and effective piece of help. I am going to install it and to refresh the whole document. I will post here the result.
    Best wishes and thank you so much
    Álvaro
  • Dear adomasven
    After having worked this week with Zotero Beta, I confirm with great pleasure that the problem seems to be fixed. Once again, thank you so much.
    Álvaro
Sign In or Register to comment.