Indexing problem

When I attach a pdf to an item, it is only indexing the first page (which I checked by looking at .zotero-ft-cache), and reports as 'Indexed: partial'. I set my maximum characters to 100000000 to try to get a full index, but no luck. Any ideas why it is not working? When I manually click the double-arrow near 'indexed' it does indeed index the whole thing.
  • There's a separate setting for PDFs, though it seems to no longer show up in the preferences. We'll restore that, but for now, go to Advanced -> Config Editor and search for fulltext.pdfMaxPages. The default is 100.
  • @quickfold11 Where do you see the "indexed: partial" and the double-arrow? Beside the attached item or in the Preferences? I do not see either of those, so wondering.

    I did notice that the pages to index setting has disappeared from Preferences, but Dan has already acknowledged that.
  • @gurdas If you highlight a pdf in the middle pane, the arrow is in the right-hand pane (where you see 'info' for items).
  • Got it, thanks.
  • Has this been sorted? Because I still don't see that option in my preferences...
  • Yes, that option was restored. It's "Maximum pages to index per file".
Sign In or Register to comment.