buggy; why underlining (with dash underlines) all references?

This new upgrade is buggy in many ways. One: it is underlining all my references for some reason. Why?
  • See https://www.zotero.org/blog/zotero-5-0-36/#faster-citing-in-large-documents

    Zotero should have prompted you before disabling auto-updating citations, though, did it not?
  • what does auto-update have to do with it? these are new references.
  • I am also getting this a lot: This.registry.citationreg.citationById[c[0]] is undefined

    and have to close out zotero and document and go back in. since the upgrade also.
  • Because once auto-update is disabled, when you add a new reference "Zotero will create a citation in the default format required by the style without taking into account other citations in the document", then "Zotero adds a dashed underline below newly added citations to remind us that they haven’t been updated (though keep in mind that existing citations later in the document might also now be incorrect)."
  • seriously? that is annoying. the document is large, don't want to keep updating because i started getting the error above. so i disabled automatic updating -- I would just update when a final draft is done.
  • I am also getting this a lot: This.registry.citationreg.citationById[c[0]] is undefined
    Try fbennett's solution here : https://forums.zotero.org/discussion/comment/300991/#Comment_300991

    Otherwise, try running through these:
  • document preferences? where is that -- i am on a mac, using word.

    i did notice that normally it happens if i change my mind in a citation and cancel and start again. but NOW it was happening all the time, even with no start-stop. I opened a new document and dumped the text into it and now it seems fine, not sure for how long.
  • is there a way to disable the dashed underline? or no, just have to live with it?
  • No, you can't disable the dashed line when you have automatic updating disabled. Your citations may be incorrect and we do want to have a visual reminder that they're not updating.

    "Document Preferences" is one of the button is Zotero's Word add-on. https://www.zotero.org/support/word_processor_plugin_usage
  • Thanks. OK, i will live with it. Glad to know it is not something weird. I will try the doc prefs when i next get into trouble.

    Thanks for the quick responses!!! It is a big help.
  • You shouldn't be getting that citationById error, so if you're getting that we'd want to see a Report ID after it occurs.
  • edited 9 days ago
    Pleased to find this forum page today. So can we all assume then that, after this update, if you rely on auto-update, Zotero will go into a mad sweep of hundreds of citations every time it opens, and on every new citation, taking tens and tens of minutes out of the day?

    The problems echoed above after this update have totally taken up my morning, and I still haven't found a way to carry on working the way I was yesterday. I disabled auto-updates and pushed refresh on getting the underlining problem noted above—my mac has been madly chugging away for about half an hour apparently checking every citation.

    My document is very large, and now, with auto-updates turned on, it is unusable. Will Zotero be looking to fix this problem? If not, can I go back to the significantly more effective previous version?

  • You are mistaken about how previous versions worked. Auto-updating is what Zotero has always done until 5.0.36. As you note, it can get slow in very large documents. That is why the option to disable automatic updating was added. 5.0.36 also included several changes to speed up the Word plugin generally, and the Zotero developers are continuing to make improvements there. In your case with the very long document, the best approach is to leave automatic updating disables and then to click the Refresh button once when you are done writing and one update occur. This workflow will be significantly more efficient that was possible in previous versions of Zotero with long documents.
  • edited 9 days ago
    So can we all assume then that, after this update, if you rely on auto-update, Zotero will go into a mad sweep of hundreds of citations every time it opens, and on every new citation, taking tens and tens of minutes out of the day?
    No. For the record, I just tried the new version in a document where I've cited >200 references and Zotero updates are nearly instantaneous with citation auto-updates disabled. With auto-updates enabled, it doesn't seem any slower than it used to be (it was, indeed, fairly slow: about 3 seconds for updating a reference in document, and upwards of 20 seconds for hitting 'Refresh'). But that is precisely what the auto-updates disabled feature is helping to prevent.

    So not all of us are seeing the problems you're reporting. And "the underlining problem noted above" is not a problem but a feature: it is the sign that Zotero won't be checking every single reference every time you add or edit a citation. In other words, with auto-updates off, you would probably be better off in larger documents.

  • edited 9 days ago
    You seem to assume that functionality has remained the same on updating this morning. I know that citations updated automatically anyway, I wasn't mistaken on that. But as of upgrading this morning my machine is now stopped still on citation, and takes forever to refresh, as noted above and in other posts, e.g.: https://forums.zotero.org/discussion/70844/zotero-update#latest.

    I've now read above about the underlining. I also clicked on the option to stop automatic updates, as Ambaylouny did, to stop the newly slow auto-update. I don't want to turn off auto-updates, because it doesn't provide an accurate record of my citations, as Zotero indeed recommends on https://www.zotero.org/blog/zotero-5-0-36/ .

    Pleased our friend Mark hasn't experienced this issue and shared with this the group. But I have, and it has been very disrupting.

    So to return to my initial post: is there a way of rewinding my Zotero version?
  • @pah67
    1. What operating system and word processor are you using?
    2. How many citations (approximately is fine) do you have in the document?
    3. What citation style are you using?
    4. How long (in your recall/estimation) it used to take to insert/edit vs how long is it taking now (with automatic updates enabled - i.e. the default option)
    5. Can you submit a Debug ID for a long-taking insert in this document?
  • edited 9 days ago
    Yes I've seen your multiple posts; for the record it's usually not needed to post a query in multiple places.

    I am on the latest Zotero version, so presumably the same as you. I was responding to your "can we all assume" — the answer is no. That is not to say you aren't experiencing frustrating problems, just that you may want to avoid assuming that everybody is running into them.

    As to reverting to an earlier version, I would await word on whether that's advisable from the developers, but for the record, you can download the last version of Zotero that doesn't have the 'disable auto-updates' feature here: https://www.zotero.org/download/client/dl?channel=release&platform=win32&version= . Note that I'm not recommending that you install this — I don't know how well it will play with your current database structure.

  • 1. Mac OS HIgh Sierra 10.13.3
    2. Around 500 (although copied and pasted a chapter into a new document with around 80/100 citations and still had the same problem)
    3. MHRA
    4. Insertion takes about 10-15 followed by another approx 10 minutes of checking all other citations.
    5. I've turned on Debug ID. Having inserted a citation, I'm still waiting for it to finish. Will post it below when finished.

    Thanks for your help.

  • (Also, we seem to be doing an unnecessary number of citation text updates on refresh, which will be fixed in the next version and improve the refresh speed when automatic updates are disabled)
  • Debug ID: D1069961838
  • @pah67
    1. What version of word processor? E.g. LibreOffice 6.0, Word 16.10
    2. Author-date or footnote/endnote version?
    2. How long in your estimation did updates used to take before the update? Matter of a few seconds or minutes?
  • 1. Word version 16.11
    2. Footnote version of MHRA
    3. Would previously take seconds, depending a little on size of doc.
  • - (Also, we seem to be doing an unnecessary number of citation text updates on refresh, which will be fixed in the next version and improve the refresh speed when automatic updates are disabled)

    Okay that sounds promising! I don't even mind if previous time doubles, so long as it just works. Will an update be quickly forthcoming? If not, is there any way I can return to the old version? I would be very grateful for a quick solution—this software is so ingrained with the process of writing this thesis.
  • edited 9 days ago
    You seem to have enabled debug logging after editing/inserting the citation. Could you produce another Debug ID by enabling the logging before clicking add/edit citation in Word?

    Note, that clicking refresh will produce a full rewrite of the document and thus will be slow. It will also perform a slow refresh if you change any of the preferences in the Document preferences, including the automatic citations pref, but you shouldn't need to change them during normal usage. After that, the subsequent inserts/edits should maintain a reasonable speed (e.g. similar to what you were seeing before).

    You can download Zotero, but it would be really helpful if you helped us debug this and ensure that the bug is fixed properly.
  • edited 9 days ago
    Thanks for this info. I really appreciate your assistance.

    I have in the past pushed refresh, and spend several minutes allowing the document to update, which was absolutely fine.But for me this has been an unprecedented shift compared to previous versions. It didn't previously refresh on every insertion, either, as it seems to now.

    Good to know in the old version there is a backstop if this can't be resolved quickly. Thanks for the link.

    Again, it took around 20 minutes to insert a citation, hopefully recorded usefully in Debug: D1165136078
  • @pah67 could you make a copy of this document, remove everything but a few paragraphs that have a few citations in it, save and send it to support@zotero.org with a link to this thread?
  • Hi everybody, as mentioned in another forum entry from yesterday, I am encountering the same issue. I just wanted to add that when Zotero is refreshing the document there is constantly a small window appearing. As this goes very fast, I couldn't read it yesterday. Today I was able to. It states that it is "busy with converting from Zotero8G66Us.rtf" (I am not entirely sure about the numbers and the rest I can't read as the window disappears very fast). I have no idea if this helps, but wanted to note it anyway.
  • Which word processor (+version) and OS (+version) are you on?
  • Microsoft Word for Mac 2011
    Version 14.5.7

    OS X Yosemite
    Version 10.10.5
  • @adomasven Thanks very much for your help. If you like, I can still send you the document. Although following the most recent update, the bug seems better software is begun working again. Thank goodness!
Sign In or Register to comment.