Non-breaking Space in Fields (Ctrl+Shift+Space)

I need to add a non-breaking space in some of the fields for different kind of documents. I tried the standard keystrokes for it, which is Ctrl+Shift+Space but this doesn't seem to work unfortunately. Do I miss something or why is it not working? Any hints and tips welcome.
  • ctrl+shift+space is not a standard keystroke for nbsp, but a MS Word implementation that some other software follows. Zotero will recognize the standard system entry method for any UTF-8 character, here for nbsp
  • Many thanks for the reply and the link. I tried to use 'AltGr+Space' to add a nbsp into a title-field in Zotero, however this didn't work out as is still shows up as a simple space in the Bibliography of LibreOffice (odf file; I updated all references from Zotero and other changes propagate nicely into LibreOffice).

    I also couldn't find out what the 'Compose' key could be on my keyboard (I tried almost every combination without luck). I'm on Linux-Mint 18.3 (Xfce); Ctrl+Shift+Space is working like a charm in LibreOffice. What am I missing here or doing wrong?
  • edited 10 days ago
    CTRL-SHFT-U, then 00a0[Enter]
  • Compose key varies by Linux distro but this should give you a start:
  • CTRL-SHFT-U, then 00a0[Enter] doesn't work either unfortunately for me - it starts giving me underlined text (u00a0). The discussion in the other forum is to complex for me I must admit (Key-assignment options are grayed out with a note stating that this is handled by the X-Server). Isn't there any other, easy way to enter a nbsp (or a way that I can configure Ctrl-Shift-Space as nbsp in Zotero)?
  • I just had an idea for a workaround - and this one seems to be working (note nice, but might be interesting for others as well as a workaround for the time being, therefore noted down here):

    1) Open LibreOffice
    2) Insert a non-breaking space (Ctrl-Shift-Space)
    3) Mark this nb space and copy it (right mouse-menu or Ctrl-C)
    4) Past it into Zotero (again right mouse-menu or Ctrl-V)

    Done :-)
  • edited 10 days ago
    Of curiosity, did you press the enter key? You can also follow with spaceber.
  • Yep, tried again and it works (the trick is to type everything until the end and not worrying about what is printed in the field in the meantime)! Since it's hard to remember (one doesn't need nbsp and other special characters that often really), I'll stick to my "workaround" as I can remember it quite easily.

    One last more general comment and suggestion in case developers are reading along: Wouldn't it be nice and an improvement to add an option to insert special characters (nbsp, nb-dash, diacritics, e.g. éâüφåø). I mean something to click through with the mouse like some editors do have. From time to time this might be something that someone needs to insert (not often though) and then it's hard to remember how to do it with keystrokes. Clicking through an option is something that will always work when needed...
Sign In or Register to comment.