Chrome connector not working; tried troubleshooting translator steps

My Chrome connector is interpreting everything as a web page and I've gone through the steps on the troubleshooting translator issues page without being able to resolve the issue.

I tested known sites such as NYTimes but it still just sees a web page.

Here are two URLs I tested:

My Debug ID: D105218514

The ScienceDirect article says 'Saving to My Library' and adds the item as a webpage rather than an article.

The NYTimes article says 'Saving to My Library' then below says "An error occurred while saving this item. Try again, and if the issue persists see 'Getting Help' for more information."

I am running Zotero version Google Chrome Version 64.0.3282.186

These same sites work successfully with the translator via Firefox so from what I can tell the issue is specific to Chrome.

Any assistance would be greatly appreciated!

  • Have you disabled all your other Chrome extensions?
  • Hi Dan,

    I thought I had done so but I had missed two extensions--my apologies! Disabling every extension did resolve the error. Could I ask if this is the only available work-around for now?

    I'm a librarian and field a lot of student questions about Zotero so just want to give them the best advice should they encounter the same issue.

    Thanks for your time!
  • That's just for troubleshooting. You'd want to re-enable your extensions one by one and figure out what was conflicting (though often when people try this they re-enable them all and it continues to work — one of life's great mysteries).
  • Hello again,

    This same issue has re-surfaced even though I have not re-enabled any of the other extensions in Chrome. All extensions are still disabled but whenever I try to save an article from a database it will only interpret it as a web page.

    It shows the newspaper icon on NYTimes, but when I attempt to save an article there I receive this error message:
    "An error occurred while saving this item. Try again, and if the issue persists see 'Getting Help' for more information."

    I receive that same error message when trying to save the academic articles from various databases. In this case I tried saving one from SAGE and one from PubMed at these URLS:


    I followed the steps to submit a report and my DeBug ID is: D395320623

    Could you please assist?

    Thank You!

  • In Connector Preferences -> Advanced click Reset Translators and see if that helps. If not, please submit a Debug ID for clicking the Reset Translators button and waiting for 10 seconds or so.
  • Hi,

    I just tested this resolution and it seems to have done the trick. Thanks for your help!
Sign In or Register to comment.