Minor UI request: papers with many authors

I was just trying to enter the author information for a paper with 22 authors, and I found I had to fight Zotero to do this.

The problem is that when you enter one author, the "+" icon to add another is inactive (grayed out) until you save and close that text field. That meant to enter my 22 authors I had to enter one author, click somewhere else in the citation window to deactivate the author text entry widget, go back and click the "+" and repeat.

Would it be possible to modify the UI so that the "+" is active while editing the author's name, and clicking it saves the currently-being-edited author, and starts a new one?

  • We'll fix that, but you can just press Shift-Enter to start a new row.
  • Thanks! Got it!
  • Another option is to type each author name in a separate line in Notepad and then just paste the entire thing as one author. Zotero will create an author entry for each line. I change the author field to "first last" (from last, first) before the paste, then switch it back after the paste.
  • edited February 24, 2018
    With gurdas’ Method, You can also enter the names as Last [tab] First, with each name on a new line, rather than switching between field modes
  • @bwiernik I can't get it to work if the field is set to the "Last, First" mode. I tried a bunch of combinations, but the first and last names get mixed up during the assignment. The full name mode works fine. Here's what I tried:

    *** Last, First Mode ***

    Last1 M1. First1
    Last2 Middle2 First2
    Last1, M1. First1
    Last2, Middle2 First2
    Last1, First1
    Last2, First2
    Last1 First1
    Last2 First2

    *** Full Name Mode ***

    First1 M1. Last1
    First2 Middle2 Last2
  • @gurdas Sorry, the tab indicator disappeared from my previous comment. Last and First names need to be separated by a tab character.
Sign In or Register to comment.