Allow pasting of BibTeX entries

From other tools such as Microsoft Word or LibreOffice, it is common to enable automatic conversion of data from other tools.

When having following BibTeX entry in the clipboard, paste does not work:

title = {Technisches Schreiben},
publisher = {Hanser Fachbuchverlag},
year = {2006},
author = {Peter Rechenberg},
edition = {3., erw. und aktualisierte Aufl.},
isbn = {9783446406957},
pagetotal = {253},
ppn_gvk = {511633173},
subtitle = {(nicht nur) für Informatiker},

Import also does not work either: "Uncrecognized format".

When copying from JabRef, Import works, but not paste. I would vote for activating "paste", too. This would really increase usability.
  • As I said on GitHub, this works via Import from Clipboard, not Paste, and the above entry imports fine for me into Zotero If you're having trouble with that, I'd guess that you have a bad BibTeX translator from BBT. Disable BBT, reset translators from the Advanced → Files and Folders pane of the Zotero preferences, and try again, and if you're still having trouble provide a Debug ID for the import attempt.

    Enabling import via Paste doesn't really make sense. This is all just text, and you can paste text into various places in Zotero, so making the behavior dependent on focus would be confusing and dangerous.
  • I think current behavior (import from clipboard) is a better way like to paste.
    CTRL+ALT+SHIF+I works for me.
  • OK, I see. In JabRef we made good experiences with Ctrl+V behavior. On the one hand, I thought, Zotero could have an advanced paste functionality in that cases where currently pasting is not allowed. On the other hand, I agree that this is opinionated and my workflow is not the common one.
  • The above reference imports cleanly with BBT.
  • I agree, easy to do
    File>Import from Clipboard

    (although it would feel more natural to use Edit>Paste if the bibtex is in memory)
  • If a text field happens to have focus, edit->paste should paste the text on the clipboard into the text field. But this means you might accidentally paste over something you actually want, and you'd have to make sure a text field is *not* focused. This makes "paste to import" a dangerous default.
Sign In or Register to comment.