The file couldn't be opened because there is no such file

This discussion was created from comments split from: No toolbar in Word 2011 for Mac.
  • Report ID: 236176970

    I have tried a number of steps and still cannot see the zotero toolbar in word 2011 for mac. I have followed these steps:
    1) Opened Zotero preferences
    2) Cite
    3) word processors
    4) clicked install microsoft word add-in
    5) i get this message

    [Exception... "The file couldn't be opened because there is no such file. @[setTemplateTypeCreator:install.m:223]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///Applications/ :: checkStatus :: line 213" data: no]

    I have also enabled the Zotero word for mac integration. However I cannot find the file on my computer
  • @Lara8 what version of Word are you using? If it is 2011 Zotero tries to install plugin files in /Applications/Microsoft Office 2011/Office/Startup/Word and is failing. Does that directory exist and is writeable?
  • I have the same problem as Lara8. I just downloaded Zotero two hours ago, (with Mac Sierra and Word 2011). I´ve tried several times to install Word plugin with no success at all and I just keep getting this: nstallation could not be completed because an error occurred.

    [Exception... "The file couldn't be opened because there is no such file. @[setTemplateTypeCreator:install.m:223]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///Applications/ :: checkStatus :: line 213" data: no]

    Does anyone have an idea?
  • @Lara8, @tarsila01: Are you using a non-admin macOS account? If so, you'll need to perform the plugin installation from an admin account. (If that's the case, we'll look into why it's not showing a better error message.)
  • edited February 13, 2018
    @dstillman I am performing the installation from an admin macOS account.
  • If you go to Finder, press Cmd-Shift-G, paste in "/Applications/Microsoft Office 2011/Office/Startup/Word", and press Go, do you end up in the "Word" folder? If so, is there anything in it, and are you able to copy a file there without being asked for a password? If not, have you renamed Microsoft Office 2011 to something else in /Applications?
  • @dstillman I read this in other threads and tried it yesterday. The Word folder is empty, I am able to copy a file but only after entering a password.
  • Can you open Terminal via Spotlight, paste in the following line, followed by Return, and copy the output here?

    ls -adl /Applications/Microsoft\ Office\ 2011/ /Applications/Microsoft\ Office\ 2011/Office/ /Applications/Microsoft\ Office\ 2011/Office/Startup/ /Applications/Microsoft\ Office\ 2011/Office/Startup/Word/
  • @dstillman
    I copied and pasted in Terminal and nothing happened. Is it maybe because all my configuration is in Spanish and it didn´t recognize the path above as it´s in English?
  • If you pressed Return, something had to have happened. Paste the full contents of the window here after pressing Return.
  • edited February 14, 2018
    I got the following:

    drwxrwxr-x@ 11 root admin 352 6 Feb 23:17 /Applications/Microsoft Office 2011/
    drwxrwxr-x@ 112 root wheel 3584 18 Apr 2017 /Applications/Microsoft Office 2011/Office/
    drwxrwxr-x 5 root wheel 160 20 May 2015 /Applications/Microsoft Office 2011/Office/Startup/
    drwxrwxr-x 2 root wheel 64 26 Feb 2014 /Applications/Microsoft Office 2011/Office/Startup/Word/
  • OK, thanks. So given those permissions, when you go to install the plugin, Zotero should prompt you to enter your password. Is that not happening, or are you getting an error before that happens?

    We'll look into why this is happening, or at least try to provide a more helpful error message.

    In the meantime, anyone who is seeing this error can follow the manually installation steps for the Word 2011 plugin. Let us know if you have any trouble with those steps.
Sign In or Register to comment.