WebDAV sync issue with Box: msg is not defined

edited February 9, 2018
Hello, all.

I suddenly have an error where I can't sync. I don't remember doing anything different.

As of now, I can't sync to Box. The red error icon tells me Webdav verification failed and to verify my file sync settings. When I do that I get the 'msg not defined' error. My box settings and path are correct. I haven't touched them. And I can log into box. I have plenty of space there.

Can someone advise me? I actually have a book due at the end of the month, and I am fact checking all of my inline citations.


  • Same thing happened to me. I guess it might caused by the recent Zotero version update since that is when I had this sync problem. Could someone help fix this?
  • (3)(+0000000): HTTP GET https://****@dav.box.com/dav/zotero/nonexistent.prop

    (1)(+0000803): HTTP GET https://****@dav.box.com/dav/zotero/nonexistent.prop failed with status code 0
    The "msg is not defined" message is a display bug in Zotero that we'll fix, but it would be triggered by a failed HTTP connection, which isn't a problem in Zotero. A bunch of people using Box for file syncing just started reporting this, so something appears to have broken on their end.

    There's a good chance that Box will fix whatever is causing this and it'll go away soon. If you're still seeing this in a few hours, you'll need to contact Box and ask why requests like the one above are failing.
  • Thanks, Dan. I have just finished placing a customer support ticket with them. I will update here if I have news.
  • I have the same problem here.
    Thanks redcloud111 for placing a customer support ticket.
    I recently checked my box and used the diagnosis tool, it failed in "Testing upload to different Box hostnames..." all 5 times.

  • Same problem here, also with Box. Eager to hear what they say.
  • I experience exactly the same issue here. Any help will be greatly appreciated. Is downgrading to a previous version a good idea? at least temporarily?
  • No, again, this isn't an issue in Zotero — it's a problem on Box's side. (The "msg is not defined" is just a display bug in Zotero when it tries to show an error message for the failed connection.)
  • See: https://status.box.com/

    The Box service claims that the problem has been resolved. Box acknowledges that this was an issue on their end and disrupted far more than Zotero Wevdav.
  • DWL

    I see their note that all uploads should be working, but I am still facing the same problem.
  • I am still experiencing this as well.
  • It might help if everyone opens a customer support ticket with Box.
  • (And just to reiterate, there's no need to mention the "msg is not defined" error in Zotero, as that's not relevant to Box. The issue is failed connections like the one shown above.)
  • Thanks, Dan. I copied the log information you sent in the customer support ticket.
  • Me too. I tried with Windows Zotero older version. Have tried upgrading Zotero to latest version ( but that hasn't helped.

    Sent the error ref: 1719549115
  • This isn’t a Zotero issue, so the Zotero version won’t matter.
  • well, let us hope the best. I am using box.com only because of Papership (for ios), otherwise I would use a different webdav provider.
  • Not sure if this should be a separate thread or not (I do use box for my webdav storage):
    One thing I've noticed, which I think may be Zotero related is that I'm getting repreated full rapid/fake syncs where it seems to be syncing all my files but really rapidly so it's not actually uploading or downloading anything.

    report id. : 321527985
  • OK, so while we don't, as a rule, provide support for misbehaving WebDAV servers, I took a look at what's happening here.

    Box has started returning invalid responses for various HTTP errors, including for the 404 error that Zotero triggers as a normal part of the Verify Server process.

    Zotero makes a request with Accept-Encoding: zip, deflate, br for a nonexistent URL. Box responds with a 404, as it should, but includes the Content-Encoding: gzip header even though the response is plaintext. This makes it an invalid HTTP response, and it will fail or behave unexpectedly in most HTTP clients.

    You can see this yourself just by trying to load https://dav.box.com/dav/zotero/nonexistent.prop in Firefox or Chrome. If you get an authentication prompt, just Esc out of it (or enter your credentials) and you'll get an error.

    Content Encoding Error

    The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

    Please contact the website owners to inform them of this problem.
    This site can’t be reached
    The webpage at https://dav.box.com/dav/zotero/nonexistent.prop might be temporarily down or it may have moved permanently to a new web address.
    So they'll need to fix that. If you have an open ticket with Box, you can point them to this comment for the technical explanation of what they need to fix.

    (Zotero is showing "msg is not defined" because the invalid response gets interpreted as a failed connection, but normally a connection fails because 1) the server couldn't be reached or 2) there was an SSL certificate/connection problem. The current code doesn't account for a situation where there's a proper SSL connection but the HTTP response is invalid. Since we don't technically need to read the response body for the 404, we can consider putting in a workaround for this, but the server is unequivocally in the wrong here, so a clearer "Invalid response from server" message would also be justified.)
  • Box has returned its status to degraded. I am not sure what it means, but it seems they are 'monitoring' it before claiming it is fully resolved.


    BTW, they have not personally responded to my post yet.
  • Ok.Dan. I've added a link to this thread. I'll also post your latest comment in my support ticket thread at Box.

  • OK, I've added a workaround in the latest Zotero beta that should fix this problem with Box (basically by ignoring the invalid part of the response).

    Note that the current beta includes a major overhaul to word processor integration that's still a bit buggy, so if you're using word processor integration and don't want to deal with unexpected issues you're probably better off waiting for either the next stable release of Zotero or for Box to fix this properly on their end.
  • edited February 11, 2018
    (I also doubt that their status page is referring to this issue, though it could be a side effect of related changes.)
  • I just try the beta and now I get a different error: channel is undefined

  • I just try the beta and now I get a different error: channel is undefined
    OK, try the latest (Help -> "Check for Updates…" if you're already on the beta).
  • Thank you very much!. Excellent support for a magnificent computer program.
  • Thank you so much!
  • OK, I am happy to log a ticket with Box, to add weight to the urgency, if someone could give me a form of words to express the problem.

  • @alaughland :
    A recent change to Box means that Box now responds to a request for a non-existent URL with an invalid HTTP response. The header on the 404 now includes Content-Encoding: gzip though the response is in plaintext.
    Because of this mismatch, HTTP clients getting the 404 are failing with Content Encoding Error. You can test this in a browser: https://dav.box.com/dav/nonexistent.prop
    The invalid 404 causes certain clients syncing with Box over WebDAV to fail, notably the reference manager Zotero (a major tool for academic research). Zotero is attempting a workaround - see https://forums.zotero.org/discussion/70311/webdav-sync-issue-with-box-msg-is-not-defined .
    Nevertheless, Box should not produce an invalid 404 response. Please could this be fixed urgently as it is likely to make other clients behave unexpectedly as well.
This discussion has been closed.