Problem installing Chrome Connector (probably IT security)

edited February 5, 2018
At my workplace, I am having trouble installing the Chrome Connector. It seems like my IT department is restricting the installation. I was able to install the Firefox Connector.

Chrome Connector:
Error message:!Atcr8aCyjBrulPAFIrxmHm-dtjxtlQ

Is this a case of IT blocking all Chrome extensions of a certain type and Zotero's connector happens to be that type? Or, they are specifically blocking the Zotero connector? Knowing more will help when I write IT

I have administrator rights on my computer. The issue was first reported to me by a colleague who I am introducing to Zotero.

Windows 10 Enterprise ver 1607 64-bit, Google Chrome 64.0.3282.119
  • I tried a few other extensions and all returned similar error message, so this must be a blanket block by my IT. Any known workarounds?
  • I don't think there's any work arounds other than talking to admins. You can probably install the bookmarklet, but it's a lot less good than the connector.
  • I tried the bookmarklet but can't get it to work. I drag-drop the button to my desktop Chrome's bookmark tab. Then, I browse to a journal article. Now, when I click on "Save to Zotero" it pops up the login page and does not move forward even if I give it the login information. I also had my local Zotero open. Could be user error since I'm new to bookmarklet.

    Does the bookmarklet save to local Zotero or
  • the bookmarklet isn't super well maintained, so this probably just doesn't work. It should save locally.
  • The bookmarklet should work saving to, and does for me in Chrome and Safari. I don't think it still works saving locally.

    When you say it doesn't move forward from the login page, what do you mean?
  • edited February 7, 2018
    When I click on "Save to Zotero" in the Chrome bookmark bar, the Zotero login page comes up. I provide the username and password, then I click on the red Login to Zotero button. But that just clears the login info I provided (instead of logging me in). Also I cannot close this login popup since there is no 'X' in the top-right.

    I tried with a Wikipedia page, too, just to be sure it's nothing to do with the journal article page I tried previously.
  • Can you actually normally log in into your Zotero account from this machine normally? If you're logged in, there shouldn't even be an auth prompt in the first place. And if you cannot, cookies may be disabled/restricted too, which is why it would be failing.
  • edited February 12, 2018
    I can login to from this machine in Firefox (and I do this almost every day).

    I have not tried Chrome in the past and presently, I can't get to the Zotero login page in Chrome. Error reported, " took too long to respond." I will try Chrome again later in the day. Just for today, I had the same issue briefly with Firefox but after a couple tries, I could login.
  • is a private IP address, so that's something on your network.
  • I tried the Chrome bookmarklet at home and it worked fine, saving to my local database. I tied a Wikipedia page and a journal article. At work, I am presented with the login screen and can't get past it. At both home and work, I first logged in to my account in Chrome.

    So, the issue is probably due to the IT policy at work?

    Can Zotero (server) be run on the local intranet so that users have no communication with Given all the IT restrictions, this might be the only way forward. I understand the setup is not straightforward but this will be done by the IT group so not worried about the complexity.
  • What you were probably seeing at home was saving to Zotero server and syncing down to your client. Bookmarklet saving to local Zotero instance has been disabled on Chrome for a few years now, because of browser security features that restrict the hosts to which the bookmarklet iframe may send requests.
  • @gurdas: Sorry, this was actually on our end — should be fixed now.
  • @dstillman Still not working in Chrome at my office. I think the problem is at my end, since it worked fine at home.
  • Are you still seeing a 10.x.x.x IP address? If so, which one?
  • Oh, the IP address error is gone; haven't seen it in recent days.

    When I said the problem is at my end (at work) I was referring to the bookmarklet not working because I cannot go beyond the login page. But at home, the bookmarklet works fine.
Sign In or Register to comment.