Times and dates parsed incorrectly

edited February 1, 2018
If a timestamp is entered into the Date field with the time first, followed by the date, Zotero parses this incorrectly. For example:



Imports with the Date field:
12:22 PM - 1 Feb 2018

Zotero parses the date as:
2018-02-12

Rather than:
2018-02-01

Can this be fixed? (An alternative would be to change the Twitter translator behavior @adamsmith @zuphilip)
  • edited February 1, 2018
    This works for me, because Twitter shows dates and times localized, which is for me without the AM and PM. Should be fixable in the Twitter translator. I will look into this...
  • This is now fixed — thanks for reporting. Your Zotero Connector should auto-update within 24 hours, or you can update manually by clicking Update Translators in the Advanced pane of the Zotero Connector preferences.

    Any further problems let us know & thanks for reporting.
Sign In or Register to comment.