Randomly detaching selected attachments

edited January 26, 2018
Hi fellow Zotero users!

Zotero seems to randomly detach opened attachments from their parent item.

I started noticing it after I switched to the new standalone post-Firefox version. However, before that I was using the standalone version as well.

It only seems to be happening to recently opened documents or the documents that are currently selected and expanded in the library. Probably when the attachment itself is still highlighted. I haven't been able to intentionally recreate the issue. So I am not sure why it happens.
  • Are you using the Zotfile plugin to move items to a different location?
  • I am using the Zotfile plugin, but not to move items to a different location.

    Sorry for my delayed response. Finishing my thesis right now :)
  • And when you say detach, what exactly do you mean? What are you seeing?
  • The attachment will detach from the parent item and appear in the folder as an independent item. Like a parentless pdf.
  • Does this happen with ZotFile disabled?
  • edited January 31, 2018
    I had disabled ZotFile, but still saw it happening.

    However, I am now able to replicate it!

    The anomaly happens under these circumstances in Standalone Zotero for Windows (10):
    1. I go to a (sub)collection
    2. I expand one parent item to reveal its child items (doesn't matter what kind of items)
    3. I expand a second parent item to reveal its child items
    4. I double click on the attached (stored copy) pdf-file to open it in my default pdf reader.
    5. I keep switching back and forth between any other application window and the Zotero window using the Alt + Tab shortcut
    6. Eventually Zotero will detach the opened attachment most of the times. Sometimes after one switch between windows, sometimes after many.

    The file doesn't actually need to be open or opened. My reader (Drawboard PDF) asks confirmation before opening the file, if I don't it can still happen.
  • Can you provide a Report ID to start?

    It might also be helpful if you could take a screenshot that shows this (or a screen recording), upload it somewhere (e.g., Dropbox), and provide a link here. I'm not totally understanding the situation, but this would be a very strange bug.

    Is this actually affecting your data, or is this a cosmetic glitch that goes away if you switch away from the collection and switch back?
  • Strange indeed. That's why it took me a while to pin down the exact circumstances.

    It is a permanent detachment. If I don't immediately notice the change and manually correct it, it would ruin my whole collection as parents and children are separated. Luckily I almost always rename the child files after their parent.

    I will upload the screenshots when I arrive home.
  • edited February 1, 2018

    I hope these screenshots'll do :)

    Report ID: 236499806
  • Can you disable Zutilo as well and then provide a Debug ID (different from a Report ID) for this happening?
  • I'm also a bit confused, because when you're alt-tabbing it doesn't seem like the parent items are still expanded (unless Windows is just bad at updating the preview).
  • Actually that screenshot was made later using AltGr as I couldn't take one using Alt + Tab. So it is a continuity error.

    Disabling Zutilo seems to have solved the problem.

    Thank you very much for your help! Now I feel a bit silly for not having tried to disable Zutilo myself and wasting your time.
  • OK, great. Assuming it comes back after re-enabling Zutilo, you can report it to the Zutilo developer on GitHub.
  • edited February 1, 2018
    Actually... after a few tries it happened again with Zutilo turned off...

    Report ID: 257668779.
  • We'd want a Debug ID for this.
  • Debug ID: D544971590
  • (3)(+0000001): Launching C:\Users\[…]\Zotero\storage\[…].pdf

    (3)(+0002916): mozSourceNode not set -- storing source node

    (3)(+0000001): Adding text/x-moz-url 0

    (3)(+0000000): Adding application/x-moz-file 0

    (3)(+0000000): Dragging with format […]
    This shows you dragging the item three seconds after opening it.

    Not really sure what's happening here, but no one else has reported this, so my guess is that either you're somehow accidentally dragging the item while trying to double-click it or something about your computer setup is causing something you're doing to be interpreted that way. (The child item wouldn't need to be dragged to the top — it just needs to be dragged a bit off its location so that the small gray line shows up between other top-level items.)

    One thing you can do is view debug output from the Help -> Debug Output Logging menu, keep that window to the side, and try to figure out exactly what you're doing when it says "mozSourceNode not set" (which is the beginning of the drag operation).
  • Debug ID: D914505997

    It might have been that I dragged it back before sending in the debug report. However, I sent in a new one while making sure I didn't do that. Now there is no "mozSourceNode not set" line.
  • edited February 1, 2018
    Another one:
    Debug ID: D1471227386

    I don't know if I am helping here, but here's another one still:
    Debug ID: D269939225
  • Those all show drags.
  • Yeah, sorry Windows' notepad apparently only searches through selected text...
  • But I don’t think we’re going to be able to debug this on our end. The only time this happens in Zotero is when you drag an item, so the debug output for this is almost certainly always going to show a drag. You’ll need to do what I suggest above and watch the debug output to figure out exactly what you’re doing on your system that’s being interpreted as a drag.
  • I think I figured it out...

    I guess I double click to quickly after I have selected a child item. Zotero will then interpret me selecting the item as the first of a double click and the third one as dragging the file from its parent. So either Zotero is very sensitive and interprets the minuscule difference between the position of my fingers on the trackpad as a drag, or I have to adjust some of my system's settings as you have been suggesting all along :)

    Maybe I have to increase the speed of a double click on Windows.
  • So the expanding of multiple parents can be cut using Occam's razor.

    But the Alt + Tab somehow still seems to play a role in all this...
Sign In or Register to comment.