[Beta] Integration error: "index is not defined"

Trying to edit a citation in an existing document (from before the integration refactor). Returns "index not defined" error. D2085455282

Subjectively, the Word for Mac 2016 add-on seems to be much slower in documents with even a modest number of citations compared to before the refactor (in addition to the errors).
  • @adomasven may be able to say more, but do you know if the performance issues are specific to the beta or happen in with 16.9?
  • Yes, it's definitely specific to the beta. In that document with the debug log above under with 16.9, the Quick Format window opens almost instantly.
  • For comparison, here is a log to load the Quick Format window in in a document with 1200 Zotero citations:

    D739106385 was the same document under the beta
  • I have a problem which is probably related.
    Report ID: 1887722737

    Using Zotero built from latest master (0bb0912).
    I use zotero-odf-scan-plugin with libreoffice.
    After inserting any citation in a libreoffice document with the rtf cite translator and converting the file to references I try to choose style for the document and when the references are updated I always get "index is not defined".

    There is no problem when using 5.0.34.
  • New beta version is out, this should be fixed. Do post if you find other issues
  • Confirmed. No problem on latest master.
  • Still getting a slightly different index error with current beta:
  • Can you consistently reproduce this, @bwiernik? Does it only happen for a specific citation in a doc? Can you reproduce in a fresh document and if so provide steps?
  • It does not occur in a fresh document. Here is an example of adding one citation, adding a bibliography, then editing the bibliography.

    (Note that the bibliography is inserted as a bookmark, not a field, and is formatted as the Normal Word style, not the Bibliography Word style. This is a bug related to Word 16.9.1, not the beta [it's present in Zotero])

    In a medium length Document B formatted using Bookmarks, not Fields, I am unable to change back to Fields. I receive the error "type not defined":

    If I delete the bibliography from the document, converting Bookmarks to Fields works, but each citation returns the manual modification warning dialogue, even though none of them have been modified (the citation text for each citation is initially the placeholder text of a date/time field with all zeroes; perhaps Zotero is getting stuck comparing that to the real intended text?). Several citations were also for some reason skipped over and converted to plain text (unlinked) rather than to Zotero Fields.

    After converting to Fields, the bibliography inserts as normal (though the formatting is incorrect as noted above):

    In a previous version of the document already using Fields, I get the error "this.registry.citationreg.citationById[c[0]] is undefined" when I try to add a new citation:

    Here is the same error in a short Document C:

    If I copy all of the text to a new document (including citations and bibliography), the error persists. If I copy everything but the bibliography, the error goes away (same if I delete the bibliography from the original document). So this appears to be an error related to corrupt bibliographies. It's happened now in four different documents with bibliographies generated before the beta integration update (all that I've tested). So it seems like a widespread issue with handling pre-update bibliographies.

    In a very long (1200 citations) Document D, doing any operation is still extremely slow (>20 minutes before the citation dialog window opens to Add Citation), and I don't have the time right now to let it run.
  • The speed issue should now be *really* fixed. We should make sure the bibliography issues are gone before we debug this.
  • edited January 31, 2018
    Okay, got Zotero to be on 5.0.11 for the Word add-in.

    The type is not defined error persists for the bookmarks version of Document B:

    So does the "citation modified" errors when I delete the bibliography, then switch Fields to Bookmarks:

    In Document C, still get an "this.citationsByIndex[idx] is undefined" error:

    But not getting it or any other registry/index errors in the Fields-version of Document B:

    Or in another document that had previously given the error:

    The first speed issue is fixed in Document D (citation window pops up within a few seconds). However, when I try to add a new citation (remember 1200 existing ones and a bibliography), it has taken >20 minutes to update and the "delay citations" window has not appeared (needed to stop and move the computer).
  • The first speed issue is fixed in Document D (citation window pops up within a few seconds). However, when I try to add a new citation (remember 1200 existing ones and a bibliography), it has taken >20 minutes to update and the "delay citations" window has not appeared (needed to stop and move the computer).
    Are you saying you didn't get the delay citations window at all, or that you stopped the update? Zotero cannot really stop a document update once it has started it, so we only show the prompt after it completes the update. This wouldn't be a problem if you were writing a big document from scratch though.
  • edited January 31, 2018
    After 20 minutes, the update hadn’t finished and I didnt get the delay citations message. Are you saying that the message wouldn’t appear until after it had _finished_ the first very long update?
  • I'm afraid so. Once again, once this is rolled out, it shouldn't be an issue. You can trigger the prompt by removing part of the document and running a refresh that would take more than 5 seconds, then restore the removed part.
  • The reported issues should be addressed in the latest beta. Thanks for reporting!
  • Yes, definitely working much smoother and faster on both mac and windows
  • No code changes regarding processing speed, so likely coincidental.
Sign In or Register to comment.