Can't add items to Zotero 5.0.34 from browser

edited January 17, 2018
I have installed the Chrome and Firefox connectors, and I have Zotero 5.0.30 installed and open, with a folder selected, but when I click the browser toolbar icons to add item to my Zotero library, nothing happens. No momentary popup, no error message...and no item added to Zotero.
  • (I have since installed 5.0.34, and it still is not working).
  • Thank you for the link. However, in step 2, "If you only see a webpage icon, make sure you're looking at a supported site. If you're not sure, try a New York Times article or an Amazon product page."

    I know that the site I'm on is not supported, but it still ought to be able to give me a bare-bones Zotero entry, right?

    Step 5: I'm running Chrome Version 63.0.3239.132 (Official Build) (64-bit) and Firefox 52.2.1 (32-bit) - the latter required an update, and after I did the update, I at first got error messages, but eventually was able to get it to add. But the Chrome connector still isn't working.

    Step 8: I'm not expecting a whole lot of metadata here. When I mouse over the icon, it just says "Save to Zotero (Web Page With Snapshot)," as I would expect for a site that doesn't have a Zotero translator. It's just that nothing happens when I click it.

    Step 10: I have disabled all extensions, including LastPass, Liner, and several Google extensions related to Docs, Sheets and Slides. The Chrome connector still doesn't work.

    Step 12: What happens in the popup? The problem is, there IS no popup when I click the Zotero button in Chrome.

    But now...I went to another website and the Zotero button worked again. I returned to the original news article, from the Kansas City Star, and it first gave me an error message, and then worked. So now I have no idea what happened, or what fixed it, but now both browser extensions seem to be working again. I believe the error messages, once I started getting popups back, may have had to do with adware on the newspaper site.

  • Yes, possible something on a webpage broke this. If you have a URL we can take a look.
Sign In or Register to comment.