Report IDs 1188326141, 1960503656, 1829540082 (dragging items to group library fails)

This sounds similar to some other problems folks have been reporting. I'll try to provide as much information as I can... I hope it helps.

There are multiple report IDs because I wasn't sure what exactly led to the problem, so I went through my actions again until I got a better idea of what was happening.

Zotero: 2.0b3
Firefox: 3.0.10
OS: Windows Vista Home Premium

I had been setting up a group library for the project I'm working on (the group is called "SLOODLE"). I had been adding several publications to the group library without any difficulties at all, mostly by using quick search or tags to find the relevant ones in my library. However, suddenly any attempts to add another publication to the group library stopped working. I would drag the publication over, then click the destination collection, and Zotero's central pane would display "An error has occurred. Please restart Firefox.". It seemed to happen with any publication from then on.

On restarting Firefox, I noticed two things:

1. The item had not been added to the group library.
2. The sync icon showed an error.

Hovering the mouse over the sync icon displayed something about a sync error trying to delete a file, and a 403 code (sorry I can't be more specific). Clicking the sync icon, it processed for a while, then displayed a new error: "Error processing uploaded data (Report ID: ea76d89e)".

Looking at the group page on the Zotero site, it looks like nothing at all from the group library was synchronised. Looking at my own library page, none of the recent changes I had made to my library locally were synchronised either.

I guessed the problem might be due to the last publication I had added to the group library, so I deleted it from the group library and attempted to sync. After prompting me to reset the sync session (presumably as my last one failed), it again reported there was an error processing uploaded data, this time report ID 1a1b7b9e. I even tried deleting the item from my own library and purging the trash, but same sync problem again (report ID 847b6ec8).

I finally tried deleting all the items from the group library (after exporting them all to an RDF file), and the sync worked. I would be happy to share that RDF file if it's helpful in resolving the issue.

Anyway... I'll stop trying to figure it out now, since I'm obviously not making it any better! :-) I hope that's useful.

(Side note: the group libraries in 2.0 is looking really awesome aside from this... great work guys! :-)
  • OK, the developer in me couldn't help but investigate just a little further. It looks the problem is caused by something about the metadata of the items being copied to the group library. (I did all of this with a completely empty group library.)

    The original item I tried copying across is a fairly simple one... just a little metadata, and an associated PDF file. I tried duplicating it in my library (by right-clicking and saying "duplicate"), and dragging the copy across... and it failed. But then I duplicated it manually, without the PDF attachment, and copying it to the group library worked.

    I guessed that maybe it was to do with whether an item was created manually or automatically, so I deleted it from my library, and got a fresh one automatically from the original source (with PDF attachment this time). Dragging that to the group library worked fine.

    Looks like that's one theory out the window. But perhaps it's got to with <i>when</i> items were added to the library. That particular item had been in my library since October 2008, when I was still running whatever stable Zotero version was out at the time (1.0 I think?).

    A lot of the error reports seemed to mention a DB query involving "creator". That makes sense, since the sync probably wants to know which group library contributor created the original item. However, what if the relevant metadata wasn't present in old versions of Zotero databases, and an upgrade somehow failed to add it?

    (Sorry I'm rambling a lot here... it's a bad habit...!)
  • Aha... glad to know I'm not going crazy... or if I am, I'm not alone! :-)

This discussion has been closed.