Cannot add/edit reference in large Word Document (>500 pages)

I run the standalone Zotero version 5.0.34 with Microsoft Word for Mac 2011. Everything works fine with documents containing fewer pages. But I am absolutely unable to add a new reference or edit an old reference into a document with over 500 pages. Upon choosing a reference to add/edit and pressing the enter key, the "update bar" appears and thereafter never leaves the screen and nothing further happens.
Please help! My book deadline is tomorrow!
  • With very long documents, Zotero can slow down. For now, you're fastest method would be to insert the citations into a new empty document, then cut and paste them into your dissertation. Then, click the Zotero "Refresh" button one time at the end to update the formatting of all of your references (and then let it run until it finishes, which might take some time).
  • (this is particularly bad, btw. on your specific setup, i.e. Zotero with Word for Mac 2011)
  • (this is particularly bad, btw. on your specific setup, i.e. Zotero with Word for Mac 2011)
    Has anybody ever done any benchmarking? With some numbers in hand, people might be better able to make decisions on whether switching to a different version of Word would be worth it (e.g. Word 2016 instead of Word 2011, or Word for Windows instead of Word for Mac).
  • Thanks bwiernik! I did as you suggested and left it overnight to refresh and it worked.
  • Probably too late for you, but we just rolled out a feature in the latest Zotero beta that allows you to disable automatic citation updates when inserting citations and refresh them manually at the end.

    I'm curious, though: for the 500-page document, had you used Zotero before, or was this the first time you were inserting Zotero citations into it? This new feature currently doesn't provide the option to disable automatic updates until after the first insertion that takes more than 5 seconds, so if it was just the size of the document itself that caused this to be so slow for you, we might want to reconsider that approach (though it seems like it would be somewhat unusual to just begin using Zotero on such a large document).
  • I have used Zotero for a few years now and have never encountered any problems before this.

    The book is divided into 12 chapters so I wrote (and referenced) the chapters in separate files. When the time came to merge each chapter into one large file, I did this slowly and cautiously expecting things to go wrong on the referencing front. Only it didn't for most part. It was only when I was merging the 9th chapter that I started to notice a slowing with the addition of each further chapter. And now that they are all merged into one document, even a simple adding of a suffix or prefix to one in citation reference takes hours to update. The Zotero beta feature that you mention would be a good way to tackle this particular point.
  • Yes, with that many citations, Zotero will slow down (as will Word itself without any add-ons slow down with that many pages if fields, cross-references, or tables of contents are used). Hours to update seems like it might be unusually long, but I guess it’s possible if you are using a note or numeric style and have an older computer. The Beta should speed it up substantially.
  • (but it's not been tested thoroughly and is, well, in beta, so make a copy of your file to try this on and test out that it works before investing too much time)
  • I'm having this issue as well. I'm getting ready to submit a draft of my dissertation (290 pages) As I'm editing references, I've been copy and pasting into a blank document, editing, and then returning to the original document. I've turned off reference updating while in the process of editing. Now that I'm ready to turn in, however, I've gone to add a bibliography, after experiences with previous drafts that simply updating a biblio from a smaller document just froze the document. I've clicked the insert biblio plug in and left it running for 3 hours and then again overnight. Both times I get "Zotero encountered an error" button and no biblio. Using MacOS 10.14.1, Zotero 5.0.58 ,and Word 16.16.4.
  • @sarahcmiller: I'm not clear on how the speed problem is related to the error message. If you're leaving it running for a long time, when does the error message appear? If you haven't restarted Zotero since you got the error, can you provide a Report ID? If you're able to provide a Debug ID (different from a Report ID) for another insert attempt, that would also be helpful so that we could see exactly where it's slowing down.
  • Back again for a final submission. I've done the same strategy - all edits in a separate document, turn off automatic updates, save bibliography until the end. Each time I leave it running for an extended time (1 hour+). I either (a) get nothing, until I try to quit and then get an immediate error message or (b) get an error message that appears 30+ minutes into the attempt, after I have left my computer running the script. The last time I got an error message, I attempted to screenshot but it disappeared. Throughout the process the Zotero word bar buttons highlight in such a way that makes it seem it is processing, but I never get to the point where there is a bibliography produced.
  • 30ish minutes in to the most recent attempt and I have the error message again. It says "Zotero experienced an error updating your document. Field reference lost @[insertFieldRaw:document.m:1363]." I had both Zotero and Word open and had run the "insert bibliography" button and then not touched either Zotero or Word other than to occasionally open the windows to check if there was an error message.
  • Via the debugging suggestion page, I've deleted all citations in captions and am now getting the message "(OSStatus error -1728.) @[canInsertField:document.m:240]"
  • Report ID is 1224287385
  • Are you sure your MacBook isn't going into standby while running a Zotero insert? If you're still working on this, could you produce a Debug ID from Zotero?

    1. In the Help menu, go to Debug Output Logging and select Enable.
    2. Attempt to insert the bibliography in word.
    3. Wait for the process to halt with an error. Do not touch Zotero or Word over this time.
    4. Return to Zotero Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • Hi! Thank you for your response. I've figured out the isuse. It definitely wasn't going into standby. I usually would leave Word and Zotero in the background running during attempts.

    What eventually fixed it was finding a corrupted citation. One citation would occasionally provoke a pop up indicating I had edited it and asking whether to keep or remove changes. I hadn't edited the citation in the document but had changed one of the author names in my Zotero database. After this happening several times (but not every time), I suspected it might be the issue. I tried removing that sentence and with some time, the bibliography eventually populated. I then re inserted the sentence with a freshly created citation from a blank document, updated and was able to get it to work.
Sign In or Register to comment.