Translator saves author names in one field, instead of two


For a few days now, I noticed that zotero saves author names from some websites in one field (combining first and last name), instead of two fields (last and first name separated). This happens on this site, for instance:

Did anything change with regards how zotero saves the references from the web, or did the website change how it presents the info to zotero?

  • Many Sage sites improperly present author names data. The translator developers would need to comment on whether it can be fixed here.
  • This used to be correct and Sage has broken this across their whole site, best I can tell. I sent them an e-mail and will see if they respond. I think I'll also implement a stop-gap solution, even though that's not great.
  • edited January 14, 2018
    The same problem is happeneng again with IEEE ASCE journals.

    Until this gets worked out; names can be made right by clicking the single-name/two-name toggle and then using the right click menu to switch name order. (Additional editing may be required.)
  • we have this fixed in Sage now as a stop-gap until we hear back from them.
    Update your translators in the connector preferences and this should work again.

    @DWL-SDCA could we get a couple of sample URLs for IEEE, please?
  • @adamsmith Sorry. You replied before I Was able to make the correction to ASCE.




Sign In or Register to comment.