Zotero only imports snapshot, not PDF

Hi there,

I'm having trouble trying with pdf attachement : Zotero will only take a snapshot, and will never join the pdf (although I've checked the box "automatically join pdfs" in prefs).
Would you have any idea if there's something obvious that I missed?

I've tried with Safari and Firefox on several websites (Jstor, Pubmed, Cairn, etc.) but can't make it work..
  • No, I don't get PDF nor snapshot with this link.
    I've tried with both Safari and Firefox.
    That's strange, because I have all options checked in the "general" panel (automatically join PDF, make a snapshot, etc.)
  • In the connector preferences (in Firefox right-click on the Save to Zotero icon and select "Preferences") what does it say under "Zotero Status"

    Does Zotero attempt to download PDFs -- i.e. do you get a red x before the PDF in the pop-up when saving -- or is there no sign of an attempted download?

    When you open a PDF in Firefox like http://www.africau.edu/images/default/sample.pdf and then click on the "Save to Zotero" button. Does that import the PDF?

  • In Zotero Status, it says "currently available".
    And both "Automatically take snapshots when saving items" and "Automatically download associated PDFs and other files when saving items" are checked.

    Zotero doesn't attempt to download PDF's, I just get metadata's.
    It doesn't work with the last link you provided. It just saves it as a web page, without any PDF attached.
    I'm wondering if I should reinstall Zotero. I get the same problem with Safari and Firefox.
  • edited 2 days ago
    The preference that controls this is currently located in the Zotero client under General. We are planning to move it into the Connectors to make it more intuitive, but for now, that's where the preference controlling this is, so you should check there.

    The preference in the Connector settings only affects saving when Zotero is closed and the saves go directly to your library at zotero.org
  • I've just found what was wrong : I've spent hours trying to make it work with a group library... which isn't doable.
    So much time for such a trivial issue...
    Thanks all for helping me though.
Sign In or Register to comment.