using ONLY ISO Date format?

the date flips between different formats (ISO and local) if I click a date field.
This is aweful.

how can I turn off local date format, and consistently ONLY use ISO at all times everywhere.

I even tried to let locale to countries that use ISO date format, but that did not help.
  • I'm not entirely sure what you're referring to.

    If you mean the actual Date field, that's always displayed in the format used by the original source, and it shouldn't change when you click on it. (When you hover over it, it shows you the parsed ISO representation that's used for citations and sorting.)

    If you're referring to the Accessed field, that would change from the displayed localized format to ISO when you click on it, just because that's how it's stored.

    Zotero always displays localized dates for Accessed, Date Added, and Date Modified (i.e., the fields that by definition have complete dates), and we don't have plans to change that. (And, in fact, there are plans to show the Date field in the localized format when it parses cleanly.)

    I don't believe OS date format settings currently affect Zotero's date display beyond using the JavaScript default for the selected region. A future version will hopefully be better at picking up custom date formats from the OS.
  • yes, I meant Accessed, Added, and Modified

    I use always ISO for everything. Windows, office, whatever. The localisation in Zotero does not work properly. Many countries use (Canada) or partly use (Germany) ISO

    But Zotero does not recognise this. and I am not talking about custom format, I am referring to ISO standard format. I believe any software should be able to display date in standard format, especially when that is internally used anyhow.

    If you don't have plans to fix this bug, then I must admit, I will stop having plans to use Zotero.

Sign In or Register to comment.