Word 2016 field codes broken, can I revert to past version of zotero?

Hello,

I'm using Zotero 5.0.33 and Microsoft word 15.41 on MacOS High Sierra. I'm having issues with field codes disappearing in word documents. Some of my in-text citations are highlighted when I click on them, but others are not highlighted, which seems to tell me they are not linked to Zotero. Deleting and re-adding those citations does not make a difference, they still do not highlight as field codes when I selected them. I reinstalled Microsoft office and the Microsoft word plugin with no effect.

Is there an easy fix for this, or if not is there a way to install the past version of zotero? I've been experiencing other bugs such as PDFs not automatically downloading through the chrome plugin as they did before and would like to revert to the past version of Zotero where everything worked perfectly.

Thanks,
Sam
  • Reverting is fairly labor intensive and support for version 4 of Zotero is running out pretty soon at which point sync will stop and other stuff will gradually stop working.

    For the Word issue, could you describe this more precisely? You're not getting the field highlighted immediately after you insert the citation? Or on saving and reopening the document? And have you tried showing field codes (alt+FN+F9) to make sure there's actually no field codes and it's not just Word not displaying that correctly?
  • The field is not highlighted immediately after I create the citation, and after closing and reopening the document those same fields are still not highlighted. In some cases I've cited the same article elsewhere in the paper and that field does highlight. So the same citation can be highlighted in some cases but not in others.

    When I display field codes, they do show up both for highlighted and un-highlighted fields. Below I've pasted the field codes for a citation to the 2013 IPCC report. The first is highlighted in word, the second is not. The only difference is the "citationID"

    { ADDIN ZOTERO_ITEM CSL_CITATION {"citationID":"a1kd89ns0jj","properties":{"formattedCitation":"(IPCC, 2013)","plainCitation":"(IPCC, 2013)"},"citationItems":[{"id":1669,"uris":["http://zotero.org/users/1731306/items/35P2B4GP"],"uri":["http://zotero.org/users/1731306/items/35P2B4GP"],"itemData":{"id":1669,"type":"report","title":"Climate Change 2013: The Physical Science Basis","collection-title":"Assessment Reports","publisher":"IPCC","number":"5","collection-editor":[{"family":"Stocker","given":"T.F."},{"family":"Qin","given":"D"},{"family":"Plattner","given":"G.K."},{"family":"Tignor","given":"M.M.B"},{"family":"Allen","given":"S.K."},{"family":"Boschung","given":"J."},{"family":"Nauels","given":"A."},{"family":"Xia","given":"Y."},{"family":"Bex","given":"V."},{"family":"Midgley","given":"P.M."}],"author":[{"family":"IPCC","given":""}],"issued":{"date-parts":[["2013"]]}}}],"schema":"https://github.com/citation-style-language/schema/raw/master/csl-citation.json"} }


    { ADDIN ZOTERO_ITEM CSL_CITATION {"citationID":"aqc0235me3","properties":{"formattedCitation":"(IPCC, 2013)","plainCitation":"(IPCC, 2013)"},"citationItems":[{"id":1669,"uris":["http://zotero.org/users/1731306/items/35P2B4GP"],"uri":["http://zotero.org/users/1731306/items/35P2B4GP"],"itemData":{"id":1669,"type":"report","title":"Climate Change 2013: The Physical Science Basis","collection-title":"Assessment Reports","publisher":"IPCC","number":"5","collection-editor":[{"family":"Stocker","given":"T.F."},{"family":"Qin","given":"D"},{"family":"Plattner","given":"G.K."},{"family":"Tignor","given":"M.M.B"},{"family":"Allen","given":"S.K."},{"family":"Boschung","given":"J."},{"family":"Nauels","given":"A."},{"family":"Xia","given":"Y."},{"family":"Bex","given":"V."},{"family":"Midgley","given":"P.M."}],"author":[{"family":"IPCC","given":""}],"issued":{"date-parts":[["2013"]]}}}],"schema":"https://github.com/citation-style-language/schema/raw/master/csl-citation.json"} }
  • edited 9 days ago
    That would seem to be an issue with Word not displaying field shadings then. I wouldn't know why, but since there are quite obviously field codes, that'd be a Word bug. But also one that wouldn't appear to affect functionality, right?

    Presumably even un-highlighted items are still in the bibliography when you create one? When you put your cursor in one, and click "add/edit citation" do you get it selected in the insert citation dialog?
  • It does not impact functionality too much; it is just causing problems for this specific project where I am going through a document replacing unlinked citations with zotero linked citations.

    If I click add/edit citation I can edit un-highlighted citations, so the only difference is the lack of highlighting.

    I've discovered that the presence or lack of highlighting is decided when I click the "add/edit citation" button and seems to depend entirely on the location in the document. In some locations, when I click "add/edit citation" the placeholder "{citation}" is not highlighted and the resulting citation is not highlighted either. However, I can create a citation elsewhere in the document and copy and paste it into one of these "bad" locations in the document and it remains highlighted.
  • In Word Preferences, Search for field shading. Is it set to Always or When Selected?
  • I've tried both settings and it makes no difference. In another twist, I've found that I can fix problematic regions of my word document by pasting them into TextEdit and then copying and pasting back into Word. After doing this, I can create new citations in those regions and they appear highlighted. So I'm guessing there's some hidden formatting that's interfering with the highlighting of fields in those regions.
  • If for some reason these would be text boxes rather than regular text, that might cause this.
Sign In or Register to comment.