Can't edit citations in word - autoformat issue?

I've been using Zotero successfully with word for years now, but I've run into an issue recently. After I add citations to a document, I am able to edit the in line citation freely. However, if I add enough references that a dash is used, then I cannot edit the in line citation. When I attempt to edit the citation again, I get the error "You must place the cursor in a Zotero citation to edit it."

In addition, I've noticed that, when I add enough citations for a dash to be needed, the font changes to Times New Roman. This makes me think that there is some autocorrect being produced by word that is corrupts the citation for Zotero.

When I insert the Bibliography, the corrupted citations still show up in the correct places.

Has anybody encountered this before or do you know of a solution?

I just upgraded to the newest version of Zotero, and I'm using Microsoft Word in Office For Mac 2016 with the newest update. My laptop is a Macbook Pro Early 2015 running macOS High Sierra (though, I may update the OS to see if that fixes anything).
  • I just tried to reinstall the Word for Mac plugin and I got the following error, if anybody thinks that this could be the source of the problem:

    Installation could not be completed because an error occurred.

    [Exception... "Word does not appear to be installed on this computer. Please install Microsoft Word and try again. @[install:install.m:159]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///Applications/ :: checkStatus :: line 212" data: no]
  • when you say "if I add enough references that a dash is used, then I cannot edit the in line citation. " you mean the citation goes over multiple lines? If not, could you maybe rephrase?
  • My apologies for the phrasing. I'm using a citation style that employs a comma between two references and a dash between more than two references.

    [1,2] does not produce an error, and I can edit it again.

    If I then add a third citation to produce [1-3], I cannot edit it again. The problem would also happen if I directly added a new citation [4-6].
  • What version of Word are you running (like Word 15.41)?
  • I'm currently using 16.9.

    But, I updated my word yesterday after I noticed the problem with Zotero. The problem was present in that earlier version, which was whatever was current circa November 2016.
  • See
    I don't think this is a general issue -- certainly isn't on Windows, but I assume bwiernik tested this on Mac Word, too.
  • Ah, thank you. It took a minute to revert to the stable version of word, but the >2 field codes in Zotero work properly again now.
Sign In or Register to comment.