Changing default font size in the Notes window

Searching the forums for this issue revealed some difficult-to-follow answers from many years ago, so I'll try here.

I am using Zotero 5.033. I am using Zotero to take notes relating to pdf documents I've uploaded.

Here's the problem: the default setting for the font in the Notes window is set to "Paragraph" (rather than other alternatives in the drop-down, such as "Heading 1," "Heading 2," etc.

This is a problem because the font size is TINY TINY TINY, and single-spaced, which makes it very hard to see. I can go in (each and every time) and change it to, say "Heading 3," which is bigger and bolder, but every time I hit "enter" and go to a new line, it defaults back to the tiny "Paragraph" for the new line. So I have to go back to the drop-down and change it again. A real annoyance.

I am aware that under "settings," there's a "Note Font Size" box that purports to allow you to set a default font size. But it has no impact on the size of the default font in the notes box. Makes no difference what I change it to. The note size is always the "Paragraph" default, which is tiny.

Can someone explain whether there's a fix for this? I have never fiddled with Zotero's code before, so I'm not sure I'd be able to do it without a kind soul walking me through the steps in detail.

Thanks very much for any help.
  • the note font size setting should definitely change the font size and does for me. You've restarted after changing that?
  • Yes, I have. The note font size setting has no impact on the display of the font within the note window.
  • what operating system?
  • @elmunc: It would be very strange for this not to work. Make sure you're testing in a new note. An existing note copied from an external source could contain embedded styling that changes the font size.

    Beyond that, I'd recommend restarting your computer, in case somehow Zotero isn't being totally closed, and if you're still having trouble take a screenshot that shows the preferences and a note, upload it somewhere (e.g., Dropbox), and provide a link here.
  • I solved the problem this way. I went into settings, advanced options, config editor, and then manually changed the value for

    extensions.zotero.note.fontSize

    to 16. That did the trick.
  • I'm having the same problem, and sadly even this suggestion (manually changing the size in the config editor) didn't seem to have any impact.

    I'm using the stand-alone Zotero program on Ubuntu - any other tips people have would be appreciated!
  • elmunc - going into the config editor and manually changing the setting worked for me. thank you!
  • I'll just reiterate that it would be very strange for there to be any difference between setting this in the General pane of the prefs and setting it in the config editor, and if there is that's something we'd want to debug. That element in the pref window is bound to that setting. If you open the config editor and filter it to that value, you should in fact see the value change when you change the pref through the UI and close the pref window (or as soon as you change the pref on macOS).
  • Thanks @elmunc - after reopening Zotero all the font sizes have gone to 16! That worked very well!
  • @scroeser said :
    "I'm having the same problem, and sadly even this suggestion (manually changing the size in the config editor) didn't seem to have any impact.

    I'm using the stand-alone Zotero program on Ubuntu - any other tips people have would be appreciated!"

    Hi,
    I am having the same problem than @scroeser and i really need to increase the font size of notes in my work (i'm visually disabled).
    Thank you in advance for help.
    Have a nice day.

    PS: Is there a way to quote someone on the forum ?
    PPS: Thanks to the developers for their outstanding work. Zotero is a great application !
  • edited October 12, 2018
    It's really just as simple as changing it in the prefs and restarting Zotero. There's nothing else to change, and the setting in the config editor would do exactly the same thing.

    If you're not seeing it change, Zotero may not be fully restarting, and you should try restarting your computer. As I say above, you should also make sure you're testing in a new note, since an existing note could have embedded formatting that affected the size.
Sign In or Register to comment.