Update to Zotero 5 - no data arrives when I sync

Been using Zotero 4 on Mac. Updated to 5 today. The panes are all totally blank. No library, no quickstart links.

I looked at the KB here https://www.zotero.org/support/kb/data_missing_after_zotero_5_upgrade

It looks like data migration was successful (ish): there is no database file in the old location ( /Users//Library/Application Support/Zotero/Profiles//zotero). Nor in Firefox profiles.

In the new location ( Users//Zotero) I have the following:
zotero.sqlite 4.6mb Created Sep 18 2011, modified today at 14:23
zotero.sqlite.1.bak 4.4mb created Dec 19 2017 (last opened same time)
zotero.sqlite.76.bak 4.8mb Created Dec 15 2017 (ditto)
zotero.sqlite.bak 4.4mb Created Dec 21 2017 (ditto)

I have tried to sync -- and when I hover over the sync button, the hovertext says "last sync: 15 minutes ago" but nothing appeared to change.

Online library still looks good. Sadly I last backed up my database file in September. I'm copying all the sqlite files I have right now.

I have access to another computer without Zotero on it and could try doing a fresh setup on it... but I'm wary of doing anything that could jeopardize my data.

What should my next move be? Thanks for any advice.
  • To add: I have not tried unlinking and relinking my account in Preferences.
  • edited December 22, 2017
    Can you provide a Report ID to start? There's a good chance this is just a startup error of some sort and your data is fine. Your databases look correct and like they have data in them.
  • Well, also, when you say "blank", do you mean that you don't even see "My Library" in the left-hand pane? If so this is definitely a startup error.
  • Interestingly, nothing happens when I click Report errors...!

    And yes, there is nothing at all in the left hand pane, or any other.

    I've restarted once with no change. Would it make sense to try a fresh download?
  • Thanks, will do and report back.
  • I'm back! When I restarted with Debug enabled, my library populated! hooray.

    Debug ID D1268495071
  • OK, that wasn't meant to actually fix anything, just to provide more info on what was happening. Try just restarting normally.
  • Ha. When I restart I first get blank panes. AND I am being prompted to update to 5.0.33.

    IF I close the update popup window, close the Zotero window, and reopen a window (i.e. not quitting the program) it looks normal, with my library.

    I suppose I should I do the update then?

    Perhaps this update prompt window was lurking there before without my seeing it. The popup opens behind the (blank) app -- or actually, now that I've watched it I see that the popup opens first but the Zotero app follows right along on top of it.
  • Ah, OK. We'll see if we can reproduce that. But yes, if you just update this should go away.
  • It seems like that would explain the behavior I saw. And I guess I was all worked up over not a whole lot!
  • thank you and happy new year!
Sign In or Register to comment.