Unwanted line breaks in Zotero footnotes, Word 2011 for Mac OSX 10.10.5

Using Zotero 5.0 with Word 2011 for Mac here.

My Zotero footnotes automatically insert 3-5 line breaks in a footnote.

So, for example the footnote starts out looking normal (initial number is superscript):
2 Martin Van Bruinessen, Agha, Shaikh, and State: The Social and Political Structures of Kurdistan (London: Zed Books, 1992);

but then Zotero refreshes and adds unnecessary breaks:
2 Martin Van Bruinessen, Agha, Shaikh, and State: The Social and Political Structures of

Kurdistan (London: Zed Books, 1992);

I try to remove these unwanted line breaks in Word, both putting my cursor at the beginning and clicking delete, and by highlighting the whole note and pushing cmd+1 to impose single spacing, but with both methods Zotero periodically re-inserts the unwanted line breaks. I checked in the Zotero classic editor, but the line breaks do not show up there. The only workaround I found is to remove field codes when I am done with the document and edit it manually. This is not ideal.

Any ideas on why this is happening and how I can fix it?
  • This isn’t Zotero, but a Word setting. Change your view in Word to “Draft”, then from the References tab, click Show Notes. From the Dropdown, choose “Footnote separator” and delete the blank lines. Then choose “Footnote continuation separator” and also delete the blank lines. You will want to delete these in Normal.dotm or whatever template you are using.
  • Thanks, @bwiernik. And sorry for a sluggish reply.

    I tried what you suggested, but found that there were no blank lines in the "Footnote continuation separator" or the "Footnote separator"

    If you're sure it's nothing in Zotero, I'll focus more on finding an issue in Word.
  • What happens when you insert regular footnotes in Word in between the Zotero-created footnotes. Same spacing issue or do those look right?
  • Thanks @adamsmith.
    The issue is inexplicably gone.
    I have tested a Word footnote between two Zotero-created ones, just to be safe, and no random spaces appeared.
    If it crops up again, I'll respond to this thread.

  • Hey @adamsmith the line break issue has re-emerged, although I cannot figure out why.

    As you advised, I double checked by going into draft view and checking to make sure there were no line breaks. No change.

    I also tried highlighting the footnote text and forcing single spacing with Cmd+1 in Word. That works temporarily, but then when Zotero updates the citations, the unwanted line breaks re-emerge. That's why I suspect the issue is emanating from Zotero.

    Any suggestions would be greatly appreciated!
    Thanks for your help.

  • What version of Word 2011 are you on? Does every item cause issues or only specific ones?
  • Thanks @adomasven and apologies for a sluggish reply.
    Word 2011 for Mac version 14.7.1

    In my experience, only the very first item has the unwanted line breaks. Others appear normally.
  • With "item" I meant Zotero items. Do only specific Zotero items cause this or is it any one? What happens when you insert regular footnotes in Word in between the Zotero-created footnotes. Same spacing issue or do those look right?
  • I see.
    I have not noticed a pattern. Any item seems to be causing the issue as long as it is the first.
  • Could you be more specific about "the first item"? Is this within a single footnote citation with multiple items cited, in which case, if there is only one cited item, does it not occur? Is it the first footnote in the document? On the page?
  • Sure thing. When I say the first item, I mean the text of the first footnote of the entire Word document, which itself is a footnote composed entirely of a Zotero-generated citation .

    I can remember these unwanted line breaks occurring when only one work is cited in the first footnote. I am unsure whether line breaks occur when there are multiple works cited in the first footnote.

    I tried opening a few documents and so far there is no issue, so I cannot test it, but when/if I see the issue again I will test what happens when I have multiple or a single work cited in the first footnote.
  • In the hour since writing my last comment, Zotero periodically updated the citations in the Word document I had looked at. Now the first footnote contains unwanted line breaks. It is only the very first footnote where these line breaks occur. This particular footnote contains multiple Zotero-generated citations as well as a prefixes I entered into the pop up window.

  • Have you noticed this in multiple documents or only this one? If you make a copy of it, remove everything but the first citation and refresh the document, do you still get these newlines? If so, could you email it to support@zotero.org with a link to this thread?
  • I have noticed this problem in multiple documents.

    I have made a copy and tried to refresh the citations. The lines have disappeared for the time being. I'll let you know if anything happens...
  • This issue also emerged in the third footnote of a different document. Still on page 1, but footnote no. 3.

    The Zotero-generated footnote contains no prefixes or suffixes, nor any of my own edits directly in Word -- just citations for four different books and articles from my Zotero library, generated by Zotero.
  • Hello again

    Just writing to let you know on Zotero ( using Word 2011 for Mac (14.7.1), Zotero citations still serve up an unwanted line break in my footnotes on the first page of a document when Zotero automatically updates the citations.

    I have tried adding trivial edits in the Classic Editor, hoping that the edits might disable automatic updates for the problem area, but this has not worked.
Sign In or Register to comment.