Firefox Zotero Button 5.0.30 not working


On my PC, with Zotero 5.0.30, Firefox 57.0.2 and connector 5.0.30, I cannot save citations anymore from sites like Pubmed/ScienceDirect/Nature/etc...
I only get the option save to Zotero with or without snapshot, and nothing happens.
Any idea how to solve ? I tried the button update status in the Connector option, I tried with Standalone open or not, to no end.

Thank you for your help,
  • Run through
    and provide the info in the final step if 1-11 don't help, in particular a specific URL (Pubmed is great for testing&debugging) and a debug ID for loading or reloading it.
  • Sorry, the troubleshooting did not help, even disabling other extensions (Google Scholar and Adblock) or resting the connector.

    An Url that does not work :
    The debug ID : D1138324268.

    Interestingly, I just noticed that it does'not work on Pubmed, on ScienceDirect, on, on, or on NYtimes websites (I always get the Save to Zotero (webpage with or without snapshot) options, and no pop up).
    However, it just worked on PMC... (for the article in question)... Strange.
  • @dstillman anything in the debug?
  • The debug log shows you successfully loading the pubmed page and saving it successfully, and then refreshing the page where translators don't load. Is this inconsistent like that? Sometimes it works and other times it doesn't?
  • edited December 13, 2017
    Well I think, looking at the debug, It recorded my discovery that it worked going through PMC, but not my first attempt on Pubmed. I double checked on PMC, and it did not worked the second time. I sent the log. Then I reloaded the PMC page, and it worked again (but still not on PubMed).

    The Pubmed page :
    The equivalent PMC page :

    and here is another debug where I only try with pubmed :

    which is way shorter, as nothing happened
  • Hi, so the issue solved itself apparently, today it works on both pudmed and ScienceDirect... Don't know what was causing it. I had a reboot for update on my PC this morning, so maybe it was enough to clear things.
    Thanks for your help
  • We've pushed out an update that logs more errors today, so if it starts breaking again please come back with another Debug ID.
Sign In or Register to comment.