Step-by-step Zotero - Libre Office Integration Mac - Help needed

edited December 8, 2017
In the past, I've only had minor issues with installing Z-LO integration. This evening I'm about to go crazy with frustration.

I've looked at:

but after more than 2.5 hours I still cannot seem to get things right.

Mac 10.12.6
Zotero version 5.0.30-beta.3+4c337e529
Zotero LibreOffice integration 5.0.8
LibreOffice 5.3.7 (64)
JRE 9.0.1 (64) [I also tried with JRE 8 versions]

I have the integration partly installed but when I select the Zotero integration within the LibreOffice extension manager there is an ! (red) and an error "the status of this extension is unknown". If I try to enable the extension LibreOffice locks up with the beachball. I've let it go for about 20 minutes. Finally, I force quit LibreOffice (I couldn't successfully simply quit.)

After a restart of my Mac, I tried again. I tried reinstalling from the Zotero program with LO closed. I tried manually installing with Zotero open and with Zotero closed. I even tried trashing and reinstalling LibreOffice.

edit: I fear that LO isn't finding my most recent Java version. I tried to locate the newer JRE version but after clicking the ADD button in the LO java options control, going to the JRE 9 files deep within my Library folder, and trying to select the proper file; I find that it is greyed out even though I'm showing hidden files.

2nd Edit: After this gets figured out I'll be pleased to help write a more detailed section concerning this for the Documentation. Installing the Z-LO integration shouldn't be so painful.
  • I faintly remember having to fight LibreOffice really hard about a year ago in an attempt to get the extension working. Current versions of LibreOffice tend to freeze and hiccup with extensions and on MacOS doubly so.

    If running into installation problems, the best bet is to attempt installing the .oxt by double-clicking, which will prompt if LO runs into any issues. If you already have a broken installation of the extension, then you should remove it first and close LO completely.

    In general, in my experience, the exclamation mark and failure to install indicates an issue with LO initialising the JRE. For MacOS specifically, you should refer to this section. I don't think things have changed since this error first occurring, so you'll still need the JDK, JRE won't do.
  • Removing LO, JDK, the Zotero integration plugin, restarting the computer and then reinstalling JDK, LO, and the plug-in (in that order) seems to have done the trick.

    Thanks for the encouragement.
Sign In or Register to comment.