Zotero 5.0 linux install problem

edited 12 days ago
Hello

I run linux mint (similar to ubuntu). Previously I used firefox with zotero as an add-on. As that no longer works, downloaded the stand-alone zotero 5 and followed the instructions. Though when I try to run zotero, a popup appears with: "Your zotero profile cannot be loaded..."

When I search for the /home/.../.zotero/zotero/ folder, I can see a l7ivbgp4.default folder and profiles.ini file. I moved this folder & deleted it and ran zotero prog again. This time it creates an empty /zotero folder with the same message.

By the way, when I first looked at the /home/.../.zotero/ folder it had root permission only. So I changed it to user. But that has not made a difference.

I have no security software running.

Any advice appreciated. (I saw another thread with a similar problem, but couldn't figure it out).

Thanks
  • edited 12 days ago
    To make sure all Zotero directories and files are owned by your user run
    sudo chown -R $USER:$USER ~/.zotero
    sudo chown -R $USER:$USER ~/Zotero


    In general it should have worked fine unless you ran zotero with sudo at some point.
  • I tried that but it made no difference.

    In case it helps anyone else, after doing more searches, I found a solution on this forum:

    rm -rf ~/.zotero
    sudo rm -rf ~/.cache/zotero
  • (I'll just note here that wiping out the Zotero profile directory — which includes settings and for some people upgrading from 4.0 could even have Zotero data in it — is not something that others should do. If you can't identify the permissions problem in the existing directory (which is definitely there in some form, because there's nothing magic about a new directory), temporarily moving .zotero out of the way is a much safer approach.)
  • edited 12 days ago
    Also, if you weren't able to delete ~/.cache/zotero without sudo, that would be an indication that you ran zotero as root at some point in the past (in which case a sudo chown on the cache directory would also work, though deleting that one is fine).
Sign In or Register to comment.