snapshots suddenly opening in MS Word not Firefox as usual

I use Zotero 5.0 standalone with Firefox (Mac OS 10.12.6). Firefox is saving to Zotero without any problem. I can open zotero records in Firefox via "view online." If I select "view snapshot," Zotero no longer loads the snapshot in Firefox. Instead, it tries to load it in MS Word, which requires multiple permissions in many dialog boxes and produces a terrible result. How can I can change the settings so that snapshot always means loading in Firefox, as it always used to be?
  • If you click Show File and try to open the snapshot from your computer file system, what happens?
  • it loads in Mac Word 2011, which is a version I no longer use but didn't remove. The icon says HTML however. strange.
  • edited December 4, 2017
    Okay, you need to change your default program on your computer for HTML files to your browser, not Word. That is a setting on your computer’s OS, not in Zotero.

    Right click on the HTML file and choose Get Info. Then choose an app to open the file and select Change for All. Then HTML files should change to open in your browser.

    (I might have some wording wrong—not at a computer at the moment.)
  • back to normal, thanks. I wonder how it got switched.
Sign In or Register to comment.