Sync error after resetting read-only group

This discussion was created from comments split from: Problem with group library sync (report ID 546413402).
  • Hi, I have a similar problem:

    I am member of a group where I'm no admin and I'm not allowed to make changes. Which is the way it should be. When I try to sync I get the above error message.

    1. I (think I) didn't actively change any item in my local copy of that group, so the error message is probably wrong in the first place.

    2. When I say "set the group back to server copy" I doesn't happen. The sync button has a red exclamation mark next to it and when I try to sync again I get the same error.

    I followed your advice to update to 5.0, but it's still the same.
    Any other ideas?

    oh yes, report code: 1199436320
  • Can you provide a Debug ID (different from a Report ID) for a sync through getting this dialog and then the error?
  • Hi, thanks for your quick reply!
    Here's the debug log: D1584794776

    I tried one more thing after that:
    As you can see from the log I am using ubuntu 16.04.3. I noticed that my zotero DB was still living in .mozilla/firefox/profile/zotero. I changed that to /home/me/Zotero by
    -- copying the zotero folder (.mozilla/...) to home/me/Zotero
    -- rename .mozilla/.../zotero to zotero.backup
    -- start Zotero in a terminal from home/me/Zotero/zotero
    -- Dialog at startup: Use new location home/me/Zotero --> yes

    But syncing produced the same error as before. Was just an idea. Hope i didn't produce more mess because I'm not sure if everything is in the place it should be now (executable, databases...)

    I can work on it again next Monday....
  • edited December 1, 2017
    start Zotero in a terminal from home/me/Zotero/zotero
    Is this really what you mean? ~/Zotero is just your Zotero data directory — you absolutely don't want the Zotero program files there. (This wouldn't affect the syncing issue (which I'll still look into), but you very much want to separate your program files from your data files.)
  • The syncing issue should be fixed in 5.0.30, available now.
  • Thanks for the hint and for fixing the syncing! I was a little confused about my Zotero installation anyway. I will put the new binary in an appropriate place...
  • Note that it's not just the binary — there are a whole set of files in the tarball, so you'll want those to all be in a separate location from the data directory files.
  • Ok, I got that. Sometimes I am a little confused about installing things. So basically there are only two folders: One with the Program (binary, libraries etc...) and one with the literature database, file storage etc.....
  • Actually three — there's also the Zotero profile directory, which contains settings.
  • That's true. I downloaded the current tarball (5.0.30) to set up everything from scratch. Everything is fine now. Especially the syncing issue with the group library seems to be solved. Thank's for that!
Sign In or Register to comment.