Zutilo uri is inaccurate in firefox 57 / zotero 5 / zutilo 2.0.3

The zutilo option to copy a zotero uri has been very useful for me, but since my move to firefox 57 it gives a wrong uri.

For instance,
zutilo gives me: http://zotero.org/users/758/items/IWG4AGRI
zotero wants: https://www.zotero.org/heckscher/items/itemKey/IWG4AGRI

Any suggestions? Thanks in advance.
  • The former should redirect to the latter.* @fcheslack, did those stop working?

    * Zutilo should use https://www.zotero.org to avoid an extra redirect to www, though. The http should be automatically changed to https by most current browsers, but might as well use that as well.
  • This theoretically worked recently? I don't think those redirects should have been working for a long time (like, when we used item IDs, not keys).
  • It doesn't redirect - I get "Error - page not found". I also tried it in Chrome, and it doesn't work there either. I think it was working only a few weeks ago -- not more than a couple of months at most.
  • This should be working again now.
  • It does! Thanks.
Sign In or Register to comment.