Can't retrieve metadata in Zotero 5

This discussion was created from comments split from: Metadata Retrieval.
  • Since you went to Zotero 5 I can no longer retrieve metadata. I have tried all the suggestions, renaming the two files as suggested. Nothing is working, so I have decided to wait till Z5 is fixed by your team. It was so much easier as an add-on to Firefox.
    Up to this, I cannot thank you enough for the service your hard work has given me. It is a marvellous program and could be more so, as I am sure it will be soon. Thank you.
  • I'm not sure which files you're referring to — renaming files isn't a standard troubleshooting step we'd recommend for this — but if you provide a Debug ID for a Retrieve Metadata attempt we'll be able to tell you more.
  • Thanks for such a prompt response. I cannot submit the Debug ID. It appears I have a faulty zotero 5. When I tried to update the 5.028 I have, when I checked first for updates it tells me the update failed because "update xml file malformed (200)".
    I have twice uninstalled zotero and reinstalled but the same problem occurs. I also tried to send the debug ID but it told me that submitting it failed. Help please. I prefer Zotero to Mendeley. But am currently using chrome.
    I am working on windows 10 x64 on a new internal hard drive.
  • Something on your system is breaking Zotero's network connection:
  • Zotero is already using proxy 5. There's no change. And when I try to update, I get the same dialog box saying that the file is malformed. Should I uninstall zotero again and restart the computer and download zotero 5 once again?
  • I had temporarily switched off the firewall as well
  • Then likely your system proxy doesn't work -- have you checked with your IT about the nature of access?
  • No, reinstalling is unlikely to make a difference — this is a problem outside of Zotero. You can generate debug output for Zotero startup with Help -> Debug Output Logging -> "Restart with Logging Enabled…", copy the output to a text editor, and search for "proxy" — Zotero should log some lines during startup to say what it's doing with regard to the proxy.

    It could also be this. You'd want to check the site certificate info for to see what it showed.
  • I think you are right about this. It is issued by Bullguard and they occupy the CN space and the O space. I don't know how to get rid of them unless I uninstall the program. Or otherwise edit them out and replace them with what you suggest. I don't know how to do that. I guess I'll have to contact them unless you suggest otherwise.
  • It has been a frustrating day. Whenever I try to submit a Debug ID, first it won't give me one, second when I try anything at all an error pops up telling me I can't do it because of some ssl fault. That's with trying to sync and 'an error occurred sending debug output' when I try to send it
  • edited November 29, 2017
    Right, your security software is breaking Zotero's network connection, so nothing that requires the network (like submitting debug output) will work.

    You'll have to disable your security software or its HTTPS-scanning feature (or you can try the certificate override instructions linked from that page, but I would strongly discourage doing that — the security software is basically impersonating every website you visit, leaving you with no way of knowing for sure that you're connecting to the real websites).
  • You were right. I uninstalled the security program and things are working perfectly now. You've been consistent and persistent in your help and I appreciate it very much. I dipped into another reference manager briefly, but I have become so used to Zotero and much prefer it. In the meantime the security program have sent a detailed email on how to fix things so I will see if it works once I have more secure wifi. Many thanks indeed. You do the world a real service.
Sign In or Register to comment.